summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-23 18:27:10 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-05-25 13:59:39 +0200
commit64f0683498cac767b35c5e868fe6c7d64cb90e93 (patch)
tree6f922e145b745961603a0ba7652bd5cf6eac6dc4 /dev-erlang/goldrush
parentdev-erlang/eredis: EAPI8 bump (diff)
downloadgentoo-64f0683498cac767b35c5e868fe6c7d64cb90e93.tar.gz
gentoo-64f0683498cac767b35c5e868fe6c7d64cb90e93.tar.bz2
gentoo-64f0683498cac767b35c5e868fe6c7d64cb90e93.zip
dev-erlang/goldrush: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-erlang/goldrush')
-rw-r--r--dev-erlang/goldrush/goldrush-0.2.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-erlang/goldrush/goldrush-0.2.0-r1.ebuild b/dev-erlang/goldrush/goldrush-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..3596ff5a5500
--- /dev/null
+++ b/dev-erlang/goldrush/goldrush-0.2.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rebar
+
+DESCRIPTION="Small Erlang app that provides fast event stream processing"
+HOMEPAGE="https://github.com/DeadZen/goldrush"
+SRC_URI="https://github.com/DeadZen/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rebar_src_prepare
+ # 'priv' directory contains only edoc.css, but doc isn't going to be built.
+ rm -r "${S}/priv" || die
+}