summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-06-14 17:11:24 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-06-14 17:11:24 +0300
commita2a33f0ee261ca13c71722e3e3168ece2bfb21df (patch)
tree32c4b74376e88236db5d7730208751d00412d7dc /dev-embedded/platformio
parentdev-python/click: Add as dependency for platformio (diff)
downloadgentoo-a2a33f0ee261ca13c71722e3e3168ece2bfb21df.tar.gz
gentoo-a2a33f0ee261ca13c71722e3e3168ece2bfb21df.tar.bz2
gentoo-a2a33f0ee261ca13c71722e3e3168ece2bfb21df.zip
dev-embedded/platformio: New package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-embedded/platformio')
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/metadata.xml8
-rw-r--r--dev-embedded/platformio/platformio-3.5.3.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
new file mode 100644
index 000000000000..c7287f7f58af
--- /dev/null
+++ b/dev-embedded/platformio/Manifest
@@ -0,0 +1 @@
+DIST platformio-3.5.3.tar.gz 96791 BLAKE2B 4b17ccec4a192704cbd185ed42eb6214cfa54a072f6d089f96c608eec7815bd3046b12f7e84355055b5026600b22c4f1c720b12caea4e281479d4c381fe8ec4f SHA512 4c5b5b0a0c4d6942f91ffcb4317149cdbdba857f17b07ad3f47db9abd97615eafbd310d0f1a2c389b485922af1df6f3a6d7831bce1f92a53540b00998c859247
diff --git a/dev-embedded/platformio/metadata.xml b/dev-embedded/platformio/metadata.xml
new file mode 100644
index 000000000000..086586c08a88
--- /dev/null
+++ b/dev-embedded/platformio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-embedded/platformio/platformio-3.5.3.ebuild b/dev-embedded/platformio/platformio-3.5.3.ebuild
new file mode 100644
index 000000000000..4aa69072b253
--- /dev/null
+++ b/dev-embedded/platformio/platformio-3.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="http://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/semantic_version-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9.1[${PYTHON_USEDEP}]
+ <dev-python/lockfile-0.13[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ <dev-python/click-6[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ <dev-python/arrow-1[${PYTHON_USEDEP}]"