summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-05 04:18:23 +0100
committerSam James <sam@gentoo.org>2022-04-05 04:18:23 +0100
commite26554af65ec4e30dcba9a4d3f48d2eddd120d86 (patch)
treeb1524819f102639792256e6a672d825a47b1a628 /dev-db
parentdev-db/sqlmap: new ebuild (diff)
downloadgentoo-e26554af65ec4e30dcba9a4d3f48d2eddd120d86.tar.gz
gentoo-e26554af65ec4e30dcba9a4d3f48d2eddd120d86.tar.bz2
gentoo-e26554af65ec4e30dcba9a4d3f48d2eddd120d86.zip
dev-db/sqlmap: style tweaks
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlmap/sqlmap-1.6.2.ebuild12
-rw-r--r--dev-db/sqlmap/sqlmap-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/dev-db/sqlmap/sqlmap-1.6.2.ebuild b/dev-db/sqlmap/sqlmap-1.6.2.ebuild
index 1844e8ba2536..7b33e4568b15 100644
--- a/dev-db/sqlmap/sqlmap-1.6.2.ebuild
+++ b/dev-db/sqlmap/sqlmap-1.6.2.ebuild
@@ -11,7 +11,7 @@ inherit bash-completion-r1 python-single-r1 wrapper
DESCRIPTION="An automatic SQL injection and database takeover tool"
HOMEPAGE="https://sqlmap.org/"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
else
@@ -39,7 +39,7 @@ fi
# termcolor (BSD)
# wininetpton (public-domain)
LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
-SLOT=0
+SLOT="0"
RDEPEND="${PYTHON_DEPS}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -49,12 +49,12 @@ DOCS=( doc/ README.md )
src_install () {
einstalldocs
- insinto "/usr/share/${PN}/"
+ insinto /usr/share/${PN}/
doins -r *
- python_optimize "${ED}/usr/share/${PN}"
+ python_optimize "${ED}"/usr/share/${PN}
- make_wrapper "${PN}" \
- "${EPYTHON} /usr/share/${PN}/sqlmap.py"
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
}
diff --git a/dev-db/sqlmap/sqlmap-9999.ebuild b/dev-db/sqlmap/sqlmap-9999.ebuild
index 1844e8ba2536..7b33e4568b15 100644
--- a/dev-db/sqlmap/sqlmap-9999.ebuild
+++ b/dev-db/sqlmap/sqlmap-9999.ebuild
@@ -11,7 +11,7 @@ inherit bash-completion-r1 python-single-r1 wrapper
DESCRIPTION="An automatic SQL injection and database takeover tool"
HOMEPAGE="https://sqlmap.org/"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
else
@@ -39,7 +39,7 @@ fi
# termcolor (BSD)
# wininetpton (public-domain)
LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
-SLOT=0
+SLOT="0"
RDEPEND="${PYTHON_DEPS}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -49,12 +49,12 @@ DOCS=( doc/ README.md )
src_install () {
einstalldocs
- insinto "/usr/share/${PN}/"
+ insinto /usr/share/${PN}/
doins -r *
- python_optimize "${ED}/usr/share/${PN}"
+ python_optimize "${ED}"/usr/share/${PN}
- make_wrapper "${PN}" \
- "${EPYTHON} /usr/share/${PN}/sqlmap.py"
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
}