summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-10-17 13:08:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-10-17 13:08:46 +0000
commitaa3ece6427a76e1bb428d5ca0e95ec71b8a4135d (patch)
treece9c3757641b08ecf6f1dabe498764c2fc1bac8e /dev-db
parentsys-boot/plymouth: add missing dep on pango[X], cairo (diff)
downloadgentoo-aa3ece6427a76e1bb428d5ca0e95ec71b8a4135d.tar.gz
gentoo-aa3ece6427a76e1bb428d5ca0e95ec71b8a4135d.tar.bz2
gentoo-aa3ece6427a76e1bb428d5ca0e95ec71b8a4135d.zip
dev-db/pgcli: add 4.1.0
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgcli/Manifest1
-rw-r--r--dev-db/pgcli/pgcli-4.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-db/pgcli/Manifest b/dev-db/pgcli/Manifest
index e446d14d1e52..ed4bf472ab0d 100644
--- a/dev-db/pgcli/Manifest
+++ b/dev-db/pgcli/Manifest
@@ -1 +1,2 @@
DIST pgcli-4.0.1.tar.gz 646421 BLAKE2B ceb0537344d1fc4c22fc424b7d1df809515778e9d1e492aead517c904ed6274f8c330e1f9bd73da377543e0d078acc8c385951a6717784205dbff0ab427b2d49 SHA512 eba490b979d7b1120eda817c3fe2afc2f2a8e4608e67e41be9b73597dc51027fbe013d5f72f8a6f2853c85395fb51f622dcf6b30c8d2185e5d9a9c1aada378ba
+DIST pgcli-4.1.0.tar.gz 651048 BLAKE2B d5fd9dcce5ebaaa2ece556891a6a7d0e6fc9a82d20490a3a0a0a6f9eb445305a965057bfff8cdbed88e5a8494a647d566f8754f67194ce674173f949382b710d SHA512 77e19e953d8793527352efdd145742de8eba09f5ebfbf054fd53e06286b0411a3e11d9fe7b3d1f1d0f8ce275eba8f7148c6f271326fe7e912ce261c2a25e890c
diff --git a/dev-db/pgcli/pgcli-4.1.0.ebuild b/dev-db/pgcli/pgcli-4.1.0.ebuild
new file mode 100644
index 000000000000..992a27446914
--- /dev/null
+++ b/dev-db/pgcli/pgcli-4.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/pgcli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/cli-helpers-2.2.1[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pgspecial[${PYTHON_USEDEP}]
+ dev-python/prompt-toolkit[${PYTHON_USEDEP}]
+ dev-python/psycopg:0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/sqlparse[${PYTHON_USEDEP}]
+ dev-python/sshtunnel[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/postgresql
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # hang while trying to create a keyring
+ # https://bugs.gentoo.org/925085
+ tests/test_main.py::test_pg_service_file
+ tests/test_ssh_tunnel.py::test_ssh_tunnel
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}