summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-09-11 05:24:23 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-10-17 10:30:39 +0300
commit261e4079d06f844fb6c0d5fb8318cc52954c6c8f (patch)
tree47faaff792a549cc7adcc7abe87f8d01d8e4ed5d /dev-db
parentapp-misc/nnn: drop 4.8 (diff)
downloadgentoo-261e4079d06f844fb6c0d5fb8318cc52954c6c8f.tar.gz
gentoo-261e4079d06f844fb6c0d5fb8318cc52954c6c8f.tar.bz2
gentoo-261e4079d06f844fb6c0d5fb8318cc52954c6c8f.zip
dev-db/litecli: add 1.12.3
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/litecli/Manifest1
-rw-r--r--dev-db/litecli/litecli-1.12.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/litecli/Manifest b/dev-db/litecli/Manifest
index 3d9ab986e9b5..2d1db04fc741 100644
--- a/dev-db/litecli/Manifest
+++ b/dev-db/litecli/Manifest
@@ -1,2 +1,3 @@
DIST litecli-1.11.0.tar.gz 887986 BLAKE2B 4f445a0d29152998ab0e27ec814f1f46af44db949c817a50e7be8af659525f13113c4a831a8bf4f31a21c7922d93e12c792e8aa44b1e8480619418aeaa72aa89 SHA512 31a97d412d5749b6e8d32b88d8b41fde79d8ca9657da9885f39dc92cb0ad00ac6ab98f931ab57806be05ba9249580f1ea5ff25849d86c2f044dc40f437b6a52e
DIST litecli-1.11.1.tar.gz 888013 BLAKE2B ed159a35df254f2ff1221a14d2af86497a51c7b7dd904963ef33ada9b0d83f2df975d550aeab94fc172c9b530e0e12c04f55e50f2363572fce51b4c90db3e0bd SHA512 54746b99a7cb5f5adf2651e685d9fab5aadc7a4974bd4411189152c6316c40bf69bc7bc64de2499cbe99165d3010ff62382fa4454bcf42c9bac3adc838666da2
+DIST litecli-1.12.3.tar.gz 884895 BLAKE2B eb4aeb8e268ae5d878aee960be68d86085ee87a1089d2f80e1f7be01c31b030ce12432656452867efc9a5b915b1c15ae69d1ab9b461a16586a1d76e001e4d51a SHA512 2b9dda031984d142a9341b19446d2cca366be98058ff57874e66fc60ee936b27f0b2900d7b00dffed058fd985028236148594372dac6a0010894d0502d7db04a
diff --git a/dev-db/litecli/litecli-1.12.3.ebuild b/dev-db/litecli/litecli-1.12.3.ebuild
new file mode 100644
index 000000000000..8ebb5cc3be86
--- /dev/null
+++ b/dev-db/litecli/litecli-1.12.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="CLI for SQLite with auto-completion and syntax highlighting"
+HOMEPAGE="https://litecli.com/ https://github.com/dbcli/litecli"
+SRC_URI="https://github.com/dbcli/litecli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/cli-helpers-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.3[${PYTHON_USEDEP}]
+ <dev-python/prompt-toolkit-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.5[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.4.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest