summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-10-18 07:05:33 +0000
committerSam James <sam@gentoo.org>2024-12-01 12:08:23 +0000
commit0b39336c6efa3b21802fa9f7f1aee48ea7d37267 (patch)
treee859d41d8a338d825c002fea1d9d0a5641f7c328 /dev-db
parenttoolchain.eclass: refactor common ada and d bootstrap code (diff)
downloadgentoo-0b39336c6efa3b21802fa9f7f1aee48ea7d37267.tar.gz
gentoo-0b39336c6efa3b21802fa9f7f1aee48ea7d37267.tar.bz2
gentoo-0b39336c6efa3b21802fa9f7f1aee48ea7d37267.zip
dev-db/mydumper: add 0.16.7.5
Docs moved to separate repo, currently not in the tarball. Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mydumper/Manifest1
-rw-r--r--dev-db/mydumper/mydumper-0.16.7.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/mydumper/Manifest b/dev-db/mydumper/Manifest
index 38c32c84e369..d55b1c17cf89 100644
--- a/dev-db/mydumper/Manifest
+++ b/dev-db/mydumper/Manifest
@@ -1 +1,2 @@
DIST mydumper-0.15.2-8.tar.gz 186389 BLAKE2B 84e08fa6460a156771f598a8a0c98c79089490f9f2fe3b90fa49efd519e2270468fe86287bab03612006489a3a1d5ab2442e76cc0f4825c8df95acec30a1c4ba SHA512 f6ca5c5756944bd2704e8a25432db1fbe14ed2a1e88b549c0799c3e0c251e524523ed39797b0b2c15c9d65c0e6e5ce3d93a60a17c77090732a8f909ab24a0126
+DIST mydumper-0.16.7-5.tar.gz 192080 BLAKE2B dac0d0700ad7a68b3bffdb13f6cb674e75b868715822ef791eb00d64ce4a41335b5f54fc4a166ee527356a4f4c5311c01aabb1c8e0c91d964b4bca5b30a546c0 SHA512 ab7f06557814318352b1a511ff06f9e094dac43d3d5638977074aa8a79c3a9b83114aa15fcafcd0a39945a8c497c725b0a8221759d55aedb424eb048f10653d8
diff --git a/dev-db/mydumper/mydumper-0.16.7.5.ebuild b/dev-db/mydumper/mydumper-0.16.7.5.ebuild
new file mode 100644
index 000000000000..245b0197d96c
--- /dev/null
+++ b/dev-db/mydumper/mydumper-0.16.7.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PV="$(ver_rs 3 -)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL"
+HOMEPAGE="https://github.com/mydumper/mydumper"
+SRC_URI="https://github.com/mydumper/mydumper/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-arch/zstd
+ dev-db/mysql-connector-c:=
+ dev-libs/glib:2
+ dev-libs/libpcre
+ dev-libs/openssl:=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13.1-atomic.patch" #654314
+ "${FILESDIR}/${PN}-0.15-Do-not-overwrite-the-user-CFLAGS.patch"
+)