summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-23 07:35:11 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-22 09:49:09 +0300
commite66c27b7c9f88c5036a0511e9e08a92ae4785ef3 (patch)
tree5f7761882da40e42d77031255d58b5b03a12cd69 /dev-db/repmgr
parentsci-astronomy/siril: Stabilize 1.2.0_rc1-r1 amd64, #912688 (diff)
downloadgentoo-e66c27b7c9f88c5036a0511e9e08a92ae4785ef3.tar.gz
gentoo-e66c27b7c9f88c5036a0511e9e08a92ae4785ef3.tar.bz2
gentoo-e66c27b7c9f88c5036a0511e9e08a92ae4785ef3.zip
dev-db/repmgr: Fix incompatible integer to pointer conversion
Closes: https://bugs.gentoo.org/883237 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32010 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/repmgr')
-rw-r--r--dev-db/repmgr/files/repmgr-5.1.0-fix-missing-getpwuid-clang16.patch12
-rw-r--r--dev-db/repmgr/repmgr-5.1.0-r1.ebuild47
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/repmgr/files/repmgr-5.1.0-fix-missing-getpwuid-clang16.patch b/dev-db/repmgr/files/repmgr-5.1.0-fix-missing-getpwuid-clang16.patch
new file mode 100644
index 000000000000..53eeb524c7c9
--- /dev/null
+++ b/dev-db/repmgr/files/repmgr-5.1.0-fix-missing-getpwuid-clang16.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/883237
+--- a/repmgr-client.c
++++ b/repmgr-client.c
+@@ -54,6 +54,8 @@
+ #include <unistd.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <sys/types.h>
++#include <pwd.h>
+
+
+ #include "repmgr.h"
diff --git a/dev-db/repmgr/repmgr-5.1.0-r1.ebuild b/dev-db/repmgr/repmgr-5.1.0-r1.ebuild
new file mode 100644
index 000000000000..7d986cfa5fc3
--- /dev/null
+++ b/dev-db/repmgr/repmgr-5.1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PostgreSQL Replication Manager"
+HOMEPAGE="http://www.repmgr.org/"
+SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-db/postgresql:*[server,static-libs]"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-fix-missing-getpwuid-clang16.patch
+)
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+ dodoc CREDITS HISTORY COPYRIGHT *.md
+
+ local PGSLOT="$(postgresql-config show)"
+ einfo "PGSLOT: ${PGSLOT}"
+
+ dodir /usr/share/postgresql-${PGSLOT}/contrib
+ dodir /usr/$(get_libdir)/postgresql-${PGSLOT}
+
+ local repmgr="/usr/bin/repmgr${PGSLOT//.}"
+ local repmgrd="/usr/bin/repmgrd${PGSLOT//.}"
+ dosym ../$(get_libdir)/postgresql-${PGSLOT}/bin/repmgr ${repmgr}
+ dosym ../$(get_libdir)/postgresql-${PGSLOT}/bin/repmgrd ${repmgrd}
+
+ insinto /etc
+ newins repmgr.conf.sample repmgr.conf
+
+ fowners postgres:postgres /etc/repmgr.conf
+ ewarn "Remember to modify /etc/repmgr.conf"
+}