summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-03 15:07:15 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-11 00:00:09 -0500
commita1de9346b9c7300f9f30698fbdad9294c1eee639 (patch)
tree3027b17542596ac41d305b6e714c2a098d9e0830 /dev-cpp
parentmedia-libs/mesa: Version bump to 19.0.2 (diff)
downloadgentoo-a1de9346b9c7300f9f30698fbdad9294c1eee639.tar.gz
gentoo-a1de9346b9c7300f9f30698fbdad9294c1eee639.tar.bz2
gentoo-a1de9346b9c7300f9f30698fbdad9294c1eee639.zip
dev-cpp/nlohmann_json: version bump to 3.6.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/Manifest1
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index e4b3cb520a16..486ceb43b520 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1 +1,2 @@
DIST nlohmann_json-3.5.0.tar.gz 114796008 BLAKE2B 94caa0374be1d38230cb13b8cd9deb3da04e4b81d361ce6baf54c1bad231945a94df74683a31660dc98413dbf23ea7596c6ed1da9cda9e02add7d7c6568973e3 SHA512 e2874e10e12070e8e1b9c01f41ce24002a3859c4aca8bf46083ea08e68f44ed6725bdcdf8e592b1e50d69975d506836c62a8e10fc6da00f0844c149dd6676996
+DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
new file mode 100644
index 000000000000..fd4f1a4593e9
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_compile() {
+ meson_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ meson_src_install
+ use doc && dodoc -r doc/html
+}