summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-cpp/glibmm
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/glibmm-2.56.1.ebuild1
-rw-r--r--dev-cpp/glibmm/glibmm-2.58.1.ebuild1
-rw-r--r--dev-cpp/glibmm/glibmm-2.60.0.ebuild1
-rw-r--r--dev-cpp/glibmm/glibmm-2.60.1.ebuild1
4 files changed, 4 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.56.1.ebuild b/dev-cpp/glibmm/glibmm-2.56.1.ebuild
index 9aa4cc3775ee..a83a68fec04d 100644
--- a/dev-cpp/glibmm/glibmm-2.56.1.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.56.1.ebuild
@@ -11,6 +11,7 @@ LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
SLOT="2"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc debug test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
diff --git a/dev-cpp/glibmm/glibmm-2.58.1.ebuild b/dev-cpp/glibmm/glibmm-2.58.1.ebuild
index 98e37553fd8a..a9698a9ca848 100644
--- a/dev-cpp/glibmm/glibmm-2.58.1.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.58.1.ebuild
@@ -11,6 +11,7 @@ LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
SLOT="2"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc debug test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
diff --git a/dev-cpp/glibmm/glibmm-2.60.0.ebuild b/dev-cpp/glibmm/glibmm-2.60.0.ebuild
index d742fe267822..ce57fc6e0e53 100644
--- a/dev-cpp/glibmm/glibmm-2.60.0.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.60.0.ebuild
@@ -11,6 +11,7 @@ LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc debug test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
diff --git a/dev-cpp/glibmm/glibmm-2.60.1.ebuild b/dev-cpp/glibmm/glibmm-2.60.1.ebuild
index 3b51cdd041bf..b119a2d526a0 100644
--- a/dev-cpp/glibmm/glibmm-2.60.1.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.60.1.ebuild
@@ -11,6 +11,7 @@ LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
SLOT="2"
KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc debug test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]