summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-04-24 11:19:17 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-24 11:21:35 +0200
commite010deea863f6efa2c7cbb6fd9eb1c447614b2e7 (patch)
treed4eaa9f8bcb5c40a75fff213c9ceafe790396943 /dev-cpp/catch
parentmedia-gfx/maim: Remove old (diff)
downloadgentoo-e010deea863f6efa2c7cbb6fd9eb1c447614b2e7.tar.gz
gentoo-e010deea863f6efa2c7cbb6fd9eb1c447614b2e7.tar.bz2
gentoo-e010deea863f6efa2c7cbb6fd9eb1c447614b2e7.zip
dev-cpp/catch: Version bump to 2.2.2
* Backport python3 patch from master * Fix choice of python interpreter automagic Closes: https://bugs.gentoo.org/650958 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-2.2.2.ebuild49
-rw-r--r--dev-cpp/catch/files/catch-2.2.2-python-automagic.patch25
-rw-r--r--dev-cpp/catch/files/catch-2.2.2-test-python3.patch44
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index b52d91471f06..fda12f94f2ed 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,3 +1,4 @@
DIST Catch-1.11.0.tar.gz 376132 BLAKE2B 23a1a6292dd91ec1c71923b4902b42b59ff6be5227b666f68ef0dc33756a58a63edd70a9b139dda0b1860c2b7a0cfec7ab9262e6447eff3184cfe28ea9b0aa77 SHA512 33085c2671f78c7562eace909564b2730eabcaf4490cd463402e66ab4ac2be1fe4fe360916c11aa589ba4a010622444126ee2ae747783b5869b5d7276361f132
DIST Catch2-2.1.1.tar.gz 481236 BLAKE2B 8a8110611aaf4ea913462884d8293bcae7d0abf3075253a26385a56b2cb5bf50b769e2117430c9712e4644f430cc16461fabfef921c5fbfceb82effb0da74e93 SHA512 64947672e614301a45efd812eb3eef98d871c9719005a441b6f6bb1dc26820bd9643ba285bcc0eaef9b212c5ab6ada4a875433c47a020ce436bcc411cdc8ad72
DIST Catch2-2.2.0.tar.gz 487585 BLAKE2B 2d8f58e8d3630cb30e438da7a169df3afff387d38dd3054cfcdb8860aa507ecc3c614471fa1110f64b0dba3d6855edfc68ee4e0b7eb97164be833827078e82fd SHA512 9dcc409939df61f84b965ee3147a7a7578b3a816ff285e103b7666115bf38a608d9a0075e06e98f93b9f06882d2e41d6c51cdaae352abbfaa2a3c1b408f22df7
+DIST Catch2-2.2.2.tar.gz 497244 BLAKE2B d5073d56b9399bd7f50bafc7758e60e31ba4434e229f92ca92cd04257f4a54cec925ad3180cc964c4f69edbaa7fc14f8af8e828421e2bb2b4f6c59eaea5cc06d SHA512 ab91036c6c3ace087d0382ce99f26b2c30a4b75d52f285619ca282a618470fe388afe47495f3b2764268d600c6834c60ba464483d06f3a1c4316c099477c8e38
diff --git a/dev-cpp/catch/catch-2.2.2.ebuild b/dev-cpp/catch/catch-2.2.2.ebuild
new file mode 100644
index 000000000000..2cce0298b3a4
--- /dev/null
+++ b/dev-cpp/catch/catch-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.2-test-python3.patch
+ "${FILESDIR}"/${PN}-2.2.2-python-automagic.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_ENABLE_WERROR=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch b/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch
new file mode 100644
index 000000000000..ecc99905d7f0
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch
@@ -0,0 +1,25 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -308,6 +308,9 @@
+
+ include(CTest)
+
++# Approval tests require python 2.7 or 3
++find_package(PythonInterp)
++
+ if (BUILD_TESTING AND NOT_SUBPROJECT)
+ add_executable(SelfTest ${TEST_SOURCES} ${IMPL_SOURCES} ${REPORTER_SOURCES} ${SURROGATE_SOURCES} ${HEADERS})
+ target_include_directories(SelfTest PRIVATE ${HEADER_DIR})
+@@ -384,7 +387,11 @@
+ set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
+
+ # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
+- add_test(NAME ApprovalTests COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
++ if(NOT ${PYTHONINTERP_FOUND})
++ message(FATAL_ERROR "Python not found, but required for running tests!")
++ endif()
++
++ add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
+ set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
+
+ if (CATCH_USE_VALGRIND)
diff --git a/dev-cpp/catch/files/catch-2.2.2-test-python3.patch b/dev-cpp/catch/files/catch-2.2.2-test-python3.patch
new file mode 100644
index 000000000000..0712f1577077
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.2.2-test-python3.patch
@@ -0,0 +1,44 @@
+From dc6b83bec9bdcc149db08711cc9dfd555a8620fa Mon Sep 17 00:00:00 2001
+From: Tom Hughes <tom@compton.nu>
+Date: Fri, 6 Apr 2018 13:59:08 +0100
+Subject: [PATCH] Support Python3 in approval tests
+
+---
+ scripts/approvalTests.py | 15 +++++++++++----
+ 1 file changed, 11 insertions(+), 4 deletions(-)
+
+diff --git a/scripts/approvalTests.py b/scripts/approvalTests.py
+index a2ab5d5a2..16cc7b7d2 100755
+--- a/scripts/approvalTests.py
++++ b/scripts/approvalTests.py
+@@ -72,10 +72,17 @@
+
+ overallResult = 0
+
++def openFile(file, mode):
++ try:
++ return open(file, mode, encoding='utf-8', errors='surrogateescape')
++ except TypeError:
++ import io
++ return io.open(file, mode, encoding='utf-8', errors='surrogateescape')
++
+ def diffFiles(fileA, fileB):
+- with open(fileA, 'r') as file:
++ with openFile(fileA, 'r') as file:
+ aLines = [line.rstrip() for line in file.readlines()]
+- with open(fileB, 'r') as file:
++ with openFile(fileB, 'r') as file:
+ bLines = [line.rstrip() for line in file.readlines()]
+
+ shortenedFilenameA = fileA.rsplit(os.sep, 1)[-1]
+@@ -139,8 +146,8 @@ def approve(baseName, args):
+ subprocess.call(args, stdout=f, stderr=f)
+ f.close()
+
+- rawFile = open(rawResultsPath, 'r')
+- filteredFile = open(filteredResultsPath, 'w')
++ rawFile = openFile(rawResultsPath, 'r')
++ filteredFile = openFile(filteredResultsPath, 'w')
+ for line in rawFile:
+ filteredFile.write(filterLine(line).rstrip() + "\n")
+ filteredFile.close()