summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-03-13 14:26:54 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-03-13 14:27:06 +0100
commit4181515ce88473246a48641bed0594b3f39e6400 (patch)
treefe0404b923ed67f8299066e0a33a3cce17452a44 /dev-ada
parentmedia-gfx/renderdoc: drop pyside2 integration (diff)
downloadgentoo-4181515ce88473246a48641bed0594b3f39e6400.tar.gz
gentoo-4181515ce88473246a48641bed0594b3f39e6400.tar.bz2
gentoo-4181515ce88473246a48641bed0594b3f39e6400.zip
dev-ada/e3-core: add 22.4.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/e3-core/Manifest1
-rw-r--r--dev-ada/e3-core/e3-core-22.4.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ada/e3-core/Manifest b/dev-ada/e3-core/Manifest
index 666c5fe4fc83..54af3d9817a5 100644
--- a/dev-ada/e3-core/Manifest
+++ b/dev-ada/e3-core/Manifest
@@ -1 +1,2 @@
DIST e3-core-22.2.0.tar.gz 383417 BLAKE2B ef595dc785b0073a53ddb06ab1ab7b1a0e9eea0131d2a15318f6355a581f83d14f61f6b0f23d4e3df4afe31e0c03a6b1b4ca8b5aefdb3f982ccaa3454f127f0d SHA512 a2bc2a183b3fed9ad2f0119406dc26857254e4a68014f618a75c062518b990e5f1f3af72e9dc321dea3f9248bd97bded87a20b5389a3e03f2d3b76bb83f56216
+DIST e3-core-22.4.0.tar.gz 484431 BLAKE2B fb0d12ea30544a33b1bd3c9e3c7571defb5226faa94fc54e5f25b8b9613a586d9e9a84f973903e150f2dff81b4806afb95df31611ced4452f2d3f892db4f6e3b SHA512 afa99afb16ec8498be62b1ed49ebd2ba057b75fa1d5b37ab5cebd40bc0f70704883211bb37be34a3be98079b7e056963f9d35c338fb20525fa009b968dd83909
diff --git a/dev-ada/e3-core/e3-core-22.4.0.ebuild b/dev-ada/e3-core/e3-core-22.4.0.ebuild
new file mode 100644
index 000000000000..f776aa9fb39e
--- /dev/null
+++ b/dev-ada/e3-core/e3-core-22.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Ease the development of portable automated build systems"
+HOMEPAGE="https://www.adacore.com/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ !app-editors/e3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-vcs/subversion
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-22.1.0-distro.patch
+ "${FILESDIR}"/${PN}-22.1.0-test.patch
+)
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_compile() {
+ local PLATFORM=x86_64-linux
+ rm src/e3/os/data/rlimit* || die
+ $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
+ distutils-r1_src_compile
+}