summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-11-06 08:10:18 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-11-06 08:10:43 +0100
commit17c13e45b33619a0c151427e4be14765814cb8d7 (patch)
treef514f53fcfd2ad777b2efff090a6802effa6445d /dev-ada/gprconfig_kb
parentdev-python/zope-interface: Stabilize 6.1 ppc, #916945 (diff)
downloadgentoo-17c13e45b33619a0c151427e4be14765814cb8d7.tar.gz
gentoo-17c13e45b33619a0c151427e4be14765814cb8d7.tar.bz2
gentoo-17c13e45b33619a0c151427e4be14765814cb8d7.zip
dev-ada/gprconfig_kb: add gcc_13 support
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/gprconfig_kb')
-rw-r--r--dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild b/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild
new file mode 100644
index 000000000000..5e6e81063638
--- /dev/null
+++ b/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
+
+inherit ada
+
+DESCRIPTION="GPR configuration knowledge base"
+HOMEPAGE="https://www.adacore.com/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:@VER@:${GCC_PV}:g" \
+ db/compilers.xml \
+ db/gnat.xml \
+ db/c.xml \
+ db/linker.xml \
+ || die
+}
+
+src_install() {
+ insinto /usr/share/gprconfig
+ doins db/*.xml
+ doins db/*.ent
+ einstalldocs
+}