summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2023-01-13 00:11:11 +0100
committerPatrice Clement <monsieurp@gentoo.org>2023-01-13 00:11:11 +0100
commitf20756175411f8e9756de1c06872b9f2d43bb313 (patch)
tree2897df9c15d6ad8b7bfbdb5ebffc686ea6289f73 /app-vim
parentnet-misc/spiped: switch string cmp to POSIX sh (diff)
downloadgentoo-f20756175411f8e9756de1c06872b9f2d43bb313.tar.gz
gentoo-f20756175411f8e9756de1c06872b9f2d43bb313.tar.bz2
gentoo-f20756175411f8e9756de1c06872b9f2d43bb313.zip
app-vim/ackvim: update dependencies
Closes: https://bugs.gentoo.org/827855 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/ackvim/ackvim-1.0.9-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/ackvim/ackvim-1.0.9-r2.ebuild b/app-vim/ackvim/ackvim-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..85fc526a2a0d
--- /dev/null
+++ b/app-vim/ackvim/ackvim-1.0.9-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="ack.vim"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: run ack from vim"
+HOMEPAGE="https://github.com/mileszs/ack.vim"
+SRC_URI="https://github.com/mileszs/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ sys-apps/ack
+ sys-apps/the_silver_searcher
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # See bug 584768.
+ mv ftplugin/qf.vim ftplugin/ackqf.vim || die
+}