summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-12-18 20:59:53 -0300
committerSam James <sam@gentoo.org>2024-01-20 11:54:53 +0000
commit77a62609be37dc9b7231ef1b0b7a9952025d4db2 (patch)
treef95d3e25e0c0f1536aaa145677bc231788d12f40 /app-text
parentsys-apps/lsd: add 1.0.0 (diff)
downloadgentoo-77a62609be37dc9b7231ef1b0b7a9952025d4db2.tar.gz
gentoo-77a62609be37dc9b7231ef1b0b7a9952025d4db2.tar.bz2
gentoo-77a62609be37dc9b7231ef1b0b7a9952025d4db2.zip
app-text/cherrytree: Version bump to 1.0.4
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34358 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cherrytree/Manifest1
-rw-r--r--app-text/cherrytree/cherrytree-1.0.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
index 747956773495..761642d944ca 100644
--- a/app-text/cherrytree/Manifest
+++ b/app-text/cherrytree/Manifest
@@ -1,3 +1,4 @@
DIST cherrytree_1.0.0.tar.xz 3746968 BLAKE2B 0f13dc25f04bc04db7d1e35de8b2f0dce45f1edcbb32705171edd19f3f508c188182036313267fb0289e98fdd64ea7fbd673f33a494997d5a873dfbe63006b0c SHA512 aa1e32be1cb99b11e158bb4d6a079a967f1b01109df76bc416cb1a11bf3628279dbf5a8ac9d476a2a9f2446f8e77d83a453891df8ea6b94ec97c3ea9b4294508
DIST cherrytree_1.0.1.tar.xz 3682988 BLAKE2B 59bb5fca46c090bfa219a0a90c4a2db6307d38844ecbe8e153159b8c39bc8e3d52b6d07b48fa10a481839666134fd74c195ad03c87c8b8698b7ebfbf83a405d5 SHA512 07d334b1af40b0195e600e676a45d9d72d1c13c8cedee6b7e576abecff0898ea248708a4f3795a9c3030e716ad814009013fd98cffe616c25a118b2b564528d1
DIST cherrytree_1.0.2.tar.xz 3732232 BLAKE2B 07fd346909ff501b88dac939e73f1eb5d30559c7a00ea1bf55ee47a0d87178434f05324509e8d8f00cec9d2188d3089baf1ff6f069eecb9c9f8ac14bddbe0c2b SHA512 917ec9a0b4160328fe281139f95ac119f211a8d5f7bb4b7e6b3fb63d9fb0bc0eedbe6286ccf8627ce718dfeff8d9f9996ffda288ce16f8d8b18a0e64a98fd5bc
+DIST cherrytree_1.0.4.tar.xz 3436940 BLAKE2B 67fec738e05f1823b9206d9a58f85be94df9c54d94e15a7408ade4801065523707e973bb0643d4b1c0ddb6c94a2a9eb00530b5c8cbd291696daa98f2d18f6767 SHA512 615c551523ef3cc7edaeeeeb632c3e0d4fa4ca1feca719a15e5b3e47f38113c1033ed13ef4a2821b14a3b4ef3a4079bce7f8f2c5643d11a4ecd6cbdc49b408e5
diff --git a/app-text/cherrytree/cherrytree-1.0.4.ebuild b/app-text/cherrytree/cherrytree-1.0.4.ebuild
new file mode 100644
index 000000000000..dd062ad78a2f
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-1.0.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1 xdg
+
+DESCRIPTION="A hierarchical note taking application (C++ version)"
+HOMEPAGE="https://www.giuspen.com/cherrytree/"
+
+SRC_URI="https://github.com/giuspen/${PN}/releases/download/v$PV/${P/-/_}.tar.xz"
+S="${WORKDIR}"/${P/-/_}
+
+KEYWORDS="~amd64 ~x86"
+
+# GPL-3 — future/src/ct (CherryTree)
+# LGPL-2.1 — future/src/7za (7zip)
+# MIT — future/src/fmt (libfmt)
+LICENSE="GPL-3 LGPL-2.1 MIT"
+SLOT="0"
+IUSE="nls test"
+
+# Has deps that aren't available in ::gentoo repo
+RESTRICT="test"
+
+RDEPEND="app-i18n/uchardet
+ app-text/gspell:=
+ >=dev-cpp/glibmm-2.64.2:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/gtksourceviewmm:3.0
+ dev-cpp/libxmlpp:2.6
+ dev-cpp/pangomm:1.4
+ dev-db/sqlite:3
+ dev-libs/fribidi
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/libxml2:2
+ dev-libs/spdlog:=
+ >=x11-libs/vte-0.70.2:2.91
+ net-misc/curl
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango"
+
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-util/cpputest )"
+
+src_prepare() {
+ # disable compress man pages
+ sed -i -e \
+ '/install(FILES/s|${MANFILE_FULL_GZ}|${CMAKE_SOURCE_DIR}/data/cherrytree.1|' \
+ CMakeLists.txt || die
+
+ # python_fix_shebang .
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXEC="${PYTHON}"
+ -DUSE_NLS=$(usex nls)
+ -DBUILD_TESTING=$(usex test)
+ -DUSE_SHARED_FMT_SPDLOG=ON
+ )
+
+ cmake_src_configure
+}