summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-21 18:29:29 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-21 18:29:29 +0200
commit500866eab31c3787fcfe1fc22dccabcac47061d2 (patch)
tree56de5ad8b8187d124cc7fc5efa3ccec6a9868e2a /app-text
parentapp-eselect/eselect-package-manager: update EAPI 6 -> 8 (diff)
downloadgentoo-500866eab31c3787fcfe1fc22dccabcac47061d2.tar.gz
gentoo-500866eab31c3787fcfe1fc22dccabcac47061d2.tar.bz2
gentoo-500866eab31c3787fcfe1fc22dccabcac47061d2.zip
app-text/libepubgen: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libepubgen/libepubgen-0.1.1-r1.ebuild (renamed from app-text/libepubgen/libepubgen-0.1.1.ebuild)10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-text/libepubgen/libepubgen-0.1.1.ebuild b/app-text/libepubgen/libepubgen-0.1.1-r1.ebuild
index 6623d64ea80e..69c7f96f801a 100644
--- a/app-text/libepubgen/libepubgen-0.1.1.ebuild
+++ b/app-text/libepubgen/libepubgen-0.1.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="EPUB generator for librevenge"
HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
@@ -18,13 +18,15 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-libs/boost
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
test? (
dev-util/cppunit
dev-libs/libxml2:2
)
"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_configure() {
econf \
@@ -36,5 +38,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}