summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-10-14 21:38:37 -0500
committerFlorian Schmaus <flow@gentoo.org>2023-10-19 11:25:43 +0200
commitde1d2bf9997e280b14c0dd7028a1bb17115f8d20 (patch)
tree7b452c70630211d88b9177ec07a1fff5c664bf50 /app-text/wgetpaste
parentmedia-gfx/fig2dev: remove unused patch(es) (diff)
downloadgentoo-de1d2bf9997e280b14c0dd7028a1bb17115f8d20.tar.gz
gentoo-de1d2bf9997e280b14c0dd7028a1bb17115f8d20.tar.bz2
gentoo-de1d2bf9997e280b14c0dd7028a1bb17115f8d20.zip
app-text/wgetpaste: add paste.gentoo.zip
From https://github.com/zlin/wgetpaste/pull/48 Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33340 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/wgetpaste')
-rw-r--r--app-text/wgetpaste/files/wgetpaste-2.33-add-paste-gentoo-zip.patch69
-rw-r--r--app-text/wgetpaste/wgetpaste-2.33-r3.ebuild (renamed from app-text/wgetpaste/wgetpaste-2.33-r2.ebuild)1
2 files changed, 70 insertions, 0 deletions
diff --git a/app-text/wgetpaste/files/wgetpaste-2.33-add-paste-gentoo-zip.patch b/app-text/wgetpaste/files/wgetpaste-2.33-add-paste-gentoo-zip.patch
new file mode 100644
index 000000000000..5b9fcc5f4618
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-2.33-add-paste-gentoo-zip.patch
@@ -0,0 +1,69 @@
+From cc41231b0ea2ec5cc0a8353fd4a9b6b71301f819 Mon Sep 17 00:00:00 2001
+From: Christopher Fore <csfore@posteo.net>
+Date: Sat, 14 Oct 2023 21:48:39 -0400
+Subject: [PATCH] Add new service - paste.gentoo.zip
+
+Specified in the code with `pgz` and in the cli for usage and brevity.
+---
+See also: https://github.com/zlin/wgetpaste/pull/48
+- Oskari
+
+ wgetpaste | 21 +++++++++++++++++++--
+ 1 file changed, 19 insertions(+), 2 deletions(-)
+
+diff --git a/wgetpaste b/wgetpaste
+index b3a537b..fc0b559 100755
+--- a/wgetpaste
++++ b/wgetpaste
+@@ -41,7 +41,7 @@ POST_generic() {
+ }
+
+ ### services
+-SERVICES="0x0 bpaste codepad dpaste gists ix_io snippets"
++SERVICES="0x0 bpaste codepad dpaste gists ix_io pgz snippets"
+ # 0x0
+ ENGINE_0x0=0x0
+ URL_0x0="http://0x0.st"
+@@ -68,6 +68,10 @@ URL_gists="https://api.github.com/gists"
+ ENGINE_ix_io=ix_io
+ URL_ix_io="http://ix.io"
+ SIZE_ix_io="1000000 1%MB"
++# paste.gentoo.zip
++ENGINE_pgz=pgz
++URL_pgz="https://paste.gentoo.zip"
++SIZE_pgz="2000000 2%MB"
+ # snippets
+ ENGINE_snippets=snippets
+ URL_snippets="https://gitlab.com/api/v4/snippets"
+@@ -139,7 +143,6 @@ POST_dpaste() {
+ }
+ REGEX_RAW_dpaste='s|^http.*|\0.txt|'
+ REGEX_URL_dpaste='s|^http.*|\0|p'
+-
+ # gists
+ LANGUAGES_gists="ActionScript Ada Apex AppleScript Arc Arduino ASP Assembly
+ Augeas AutoHotkey Batchfile Befunge BlitzMax Boo Brainfuck Bro C C# C++
+@@ -230,6 +233,20 @@ POST_lodgeit() {
+ POST_generic "submit=Paste! % % language % % code" "$1" "$2" "$3" "$4" "$5" "$6"
+ }
+ REGEX_RAW_lodgeit='s|^\(https\?://[^/]*/\)show\(/[[:alnum:]]*/\)$|\1raw\2|'
++# paste.gentoo.zip
++escape_input_pgz() { echo "$*"; }
++POST_pgz() {
++ local content="${6}"
++ local boundary="WGETPASTE-3d8dfd9bff2b12a7410328d2ec1ed145"
++ echo "--${boundary}"
++ echo "Content-Disposition: form-data; name=\"file\""
++ echo ""
++ echo "${content}"
++ echo "--${boundary}--"
++ ADDITIONAL_HEADERS_pgz=("Content-Type: multipart/form-data; boundary=${boundary}")
++}
++REGEX_RAW_pgz='s|^http.*|\0|'
++REGEX_URL_pgz='s|^http.*|\0|p'
+ # pinnwand
+ LANGUAGES_pinnwand="ABAP ActionScript%3 ActionScript Ada ANTLR ANTLR%With%ActionScript%Target \
+ ANTLR%With%CPP%Target ANTLR%With%C#%Target ANTLR%With%Java%Target ANTLR%With%ObjectiveC%Target \
+--
+2.41.0
+
diff --git a/app-text/wgetpaste/wgetpaste-2.33-r2.ebuild b/app-text/wgetpaste/wgetpaste-2.33-r3.ebuild
index d7840c31c259..89f63061351c 100644
--- a/app-text/wgetpaste/wgetpaste-2.33-r2.ebuild
+++ b/app-text/wgetpaste/wgetpaste-2.33-r3.ebuild
@@ -22,6 +22,7 @@ RDEPEND="net-misc/wget[ssl?]"
PATCHES=(
"${FILESDIR}"/${PN}-2.33-tests.patch
"${FILESDIR}"/${PN}-2.33-disable-sprunge.patch
+ "${FILESDIR}"/${PN}-2.33-add-paste-gentoo-zip.patch
)
src_prepare() {