summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-12 23:27:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-13 18:11:53 +0100
commite56ffc495f6f85e8d7749271d4a90d8e7f373198 (patch)
tree6bf7bccd1ddfbeab56a22b7abfb6b2b540a0aa83 /app-text/poppler
parentmedia-gfx/inkscape: Fix build w/ app-text/poppler-24.12 (diff)
downloadgentoo-e56ffc495f6f85e8d7749271d4a90d8e7f373198.tar.gz
gentoo-e56ffc495f6f85e8d7749271d4a90d8e7f373198.tar.bz2
gentoo-e56ffc495f6f85e8d7749271d4a90d8e7f373198.zip
app-text/poppler: 25.01.0 version bump, subslot bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/Manifest2
-rw-r--r--app-text/poppler/poppler-25.01.0.ebuild157
-rw-r--r--app-text/poppler/poppler-9999.ebuild4
3 files changed, 161 insertions, 2 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index ab17daebdeac..6f7117d11954 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,4 +2,6 @@ DIST poppler-24.11.0.tar.xz 1922804 BLAKE2B 2ee77ddfd49ab4b3f486fcd160be21fdf2d4
DIST poppler-24.11.0.tar.xz.sig 833 BLAKE2B 7ef6e5bd5659c91dc5924367b7875a3946116a71b0cc02d98a1cccd51d4a46b8d8b219681e576ba7ea27f736c8a5220ae98acb0f454ac4785c03d1c66d104046 SHA512 7b935eaa99c4c3e8706bfcb010245babf5a4f08f6809a340239a0c40eed0a79472c34e4722d4b480e20fa6618106cc5e9583e209e025689f1fae06c5c499f95f
DIST poppler-24.12.0.tar.xz 1934024 BLAKE2B c1148608430c466ffa61ae420a287642b1b147efec59fee664f446b2f283b3f24841cee5d1ab1dbb5df9db12724e92137e8eb7e559fbd6f6d0941f6b194b2ed0 SHA512 23abac84fe1074eb8fb01ca94d4c1a3397c20fb9f1505993bc4c8286ce6a0d664cbc8770b912d1fb5d3621a801746d1e9353ca45ee4666958c6226a6512bd444
DIST poppler-24.12.0.tar.xz.sig 833 BLAKE2B 48969ab45646935594286ae75205b3f36972d4e360ecb7b60538ddb9b6d329e1ecb59ba10b18f0d191891be78f24cfe0f14c4e6ffbf2f0f453889416cc22c393 SHA512 708186f11d84666e6ffaf090f5181855d54e78dc606451890268246e0ae1791ce4616ce069cde902ee80dddae9542ebf78ca66bd9dcc6833b75529b20ffd9657
+DIST poppler-25.01.0.tar.xz 1942508 BLAKE2B e6d7711ac09abb981cca915999bfaeb16032989a8b1fed9eba06e4d5cb3bfd6bb76496243fb77fb05a9fe9b6a327571adffea4d943877b1f2693014bc2aeec52 SHA512 9791e32099a13a8e80c87f7be874da0fee21f84246c0d9e37ad0e902189e9bf027a35757e26a1b2bf161a098d0bed29abc1550301767d686928ed77c37977b93
+DIST poppler-25.01.0.tar.xz.sig 833 BLAKE2B 4b24055737c95e50d18a490809e4f24e14c730c474a623d507c6b6a1a38c0521becc42e7a3fb0e35a2697110a534a66611b77c98ab71ebfbfb6dfd674725723d SHA512 42600fc952416dc7b5f36c9696de5ee356d6eb50980fd06d3409923bfdd66d83e594b3a1eb6a499f6d51e516477a39d60f289d35789f53c2edb590c09d7c83b0
DIST poppler-test-ff3133cdb6cb496ee1d2c3231bfa35006a5e8410.tar.bz2 5207226 BLAKE2B 15153457989a53301bcdc3468ab2b06b637457199004651b39ea848f488f8a2ba594ce2e36091de4fd06fc0a52b783c6b2ee243ac5d95ce1e9db7483ea880829 SHA512 335cd3d55fc6e28331e791e5b63a08d293abc70764a9f314b2c590c26a5a78b38243c74f988bb95afffe0bdcc54dee1e633dbf1672b19a290be40a298e16995f
diff --git a/app-text/poppler/poppler-25.01.0.ebuild b/app-text/poppler/poppler-25.01.0.ebuild
new file mode 100644
index 000000000000..623628e1947e
--- /dev/null
+++ b/app-text/poppler/poppler-25.01.0.ebuild
@@ -0,0 +1,157 @@
+# Copyright 2005-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/poppler/poppler"
+ SLOT="0/9999"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/aacid.asc
+ inherit verify-sig
+
+ TEST_COMMIT="ff3133cdb6cb496ee1d2c3231bfa35006a5e8410"
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ SRC_URI+=" test? ( https://gitlab.freedesktop.org/poppler/test/-/archive/${TEST_COMMIT}/test-${TEST_COMMIT}.tar.bz2 -> ${PN}-test-${TEST_COMMIT}.tar.bz2 )"
+ SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ SLOT="0/145" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="boost cairo cjk curl +cxx debug doc gpgme +introspection +jpeg +jpeg2k +lcms nss png qt5 qt6 test tiff +utils"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.13
+ >=media-libs/freetype-2.10
+ sys-libs/zlib
+ cairo? (
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/cairo-1.16
+ introspection? ( >=dev-libs/gobject-introspection-1.72:= )
+ )
+ curl? ( net-misc/curl )
+ gpgme? ( >=app-crypt/gpgme-1.19.0:=[cxx] )
+ jpeg? ( >=media-libs/libjpeg-turbo-1.1.0:= )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.49 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ >=dev-qt/qtcore-5.15.2:5
+ >=dev-qt/qtgui-5.15.2:5
+ >=dev-qt/qtxml-5.15.2:5
+ )
+ qt6? ( dev-qt/qtbase:6[gui,xml] )
+ tiff? ( media-libs/tiff:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+DEPEND="${COMMON_DEPEND}
+ boost? ( >=dev-libs/boost-1.74 )
+ test? (
+ qt5? (
+ >=dev-qt/qttest-5.15.2:5
+ >=dev-qt/qtwidgets-5.15.2:5
+ )
+ qt6? ( dev-qt/qtbase:6[widgets] )
+ )
+"
+BDEPEND="
+ >=dev-util/glib-utils-2.64
+ virtual/pkgconfig
+"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-aacid-20230907 )"
+fi
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-23.10.0-qt-deps.patch"
+ "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
+ elif use verify-sig ; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if tc-is-clang ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ append-lfs-flags # bug #898506
+
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=$(usex test $(usex qt5))
+ -DBUILD_QT6_TESTS=$(usex test $(usex qt6))
+ -DBUILD_CPP_TESTS=$(usex test)
+ -DBUILD_MANUAL_TESTS=$(usex test)
+ -DTESTDATADIR="${WORKDIR}"/test-${TEST_COMMIT}
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_BOOST="$(usex boost)"
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DENABLE_GPGME=$(usex gpgme)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_LCMS=$(usex lcms)
+ -DENABLE_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ -DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT6=$(usex qt6)
+ -DENABLE_LIBTIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 60012e10a50d..623628e1947e 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2005-2024 Gentoo Authors
+# Copyright 2005-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ else
SRC_URI+=" test? ( https://gitlab.freedesktop.org/poppler/test/-/archive/${TEST_COMMIT}/test-${TEST_COMMIT}.tar.bz2 -> ${PN}-test-${TEST_COMMIT}.tar.bz2 )"
SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- SLOT="0/144" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/145" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"