summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/dvipdfmx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/dvipdfmx')
-rw-r--r--app-text/dvipdfmx/Manifest1
-rw-r--r--app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild60
-rw-r--r--app-text/dvipdfmx/files/20090708-fix_file_collisions.patch11
-rw-r--r--app-text/dvipdfmx/metadata.xml17
4 files changed, 89 insertions, 0 deletions
diff --git a/app-text/dvipdfmx/Manifest b/app-text/dvipdfmx/Manifest
new file mode 100644
index 000000000000..9c4bed12196b
--- /dev/null
+++ b/app-text/dvipdfmx/Manifest
@@ -0,0 +1 @@
+DIST dvipdfmx-20110311.tar.gz 616749 SHA256 ba7b052a17d8be4d94d64186fa77ddcce52ab5ee755b02e8444c56450ad2cbbe SHA512 0d5fc5dba35b0fe7074a392a99338861ce999809e5c20da830ebd6ba4c8ba45819054463862f3025d3a30c78aad227d3e014651ebf5e7976e86a3d9dac93d406 WHIRLPOOL 37bb24e9c8afbddf74e23896b3f106a12ed2441a43efb27944f6cc01467e8c5c53d7534df250ce65255b18ac62288efc0f7930e0debf8a1a4c35d49d0e9ed301
diff --git a/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild b/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild
new file mode 100644
index 000000000000..15f315737ed6
--- /dev/null
+++ b/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit autotools eutils texlive-common flag-o-matic toolchain-funcs
+
+DESCRIPTION="DVI to PDF translator with multi-byte character support"
+HOMEPAGE="http://project.ktug.or.kr/dvipdfmx/"
+SRC_URI="http://project.ktug.or.kr/${PN}/snapshot/latest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND="app-text/libpaper
+ >=media-libs/libpng-1.2:0
+ sys-libs/zlib
+ dev-libs/kpathsea
+ app-text/libpaper"
+RDEPEND="${DEPEND}
+ virtual/tex-base
+ >=app-text/poppler-0.12.3-r3
+ app-text/poppler-data"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/20090708-fix_file_collisions.patch
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+}
+
+src_install() {
+ # Override dvipdfmx.cfg default installation location so that it is easy to
+ # modify it and it gets config protected. Symlink it from the old location.
+ emake configdatadir="${EPREFIX}/etc/texmf/dvipdfmx" \
+ glyphlistdatadir="${EPREFIX}/usr/share/texmf-site/fonts/map/glyphlist" \
+ mapdatadir="${EPREFIX}/usr/share/texmf-site/fonts/map/dvipdfmx" \
+ DESTDIR="${D}" \
+ install || die
+ dosym /etc/texmf/dvipdfmx/dvipdfmx.cfg /usr/share/texmf-site/dvipdfmx/dvipdfmx.cfg || die
+
+ # Symlink poppler-data cMap, bug #201258
+ dosym /usr/share/poppler/cMap /usr/share/texmf-site/fonts/cmap/cMap || die
+ dodoc AUTHORS ChangeLog README || die
+
+ # Remove symlink conflicting with app-text/dvipdfm (bug #295235)
+ rm "${ED}"/usr/bin/ebb
+}
+
+pkg_postinst() {
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}
diff --git a/app-text/dvipdfmx/files/20090708-fix_file_collisions.patch b/app-text/dvipdfmx/files/20090708-fix_file_collisions.patch
new file mode 100644
index 000000000000..2b89de6b3649
--- /dev/null
+++ b/app-text/dvipdfmx/files/20090708-fix_file_collisions.patch
@@ -0,0 +1,11 @@
+diff -urN dvipdfmx-20090708/data/Makefile.am dvipdfmx-20090708.new/data/Makefile.am
+--- dvipdfmx-20090708/data/Makefile.am 2009-05-01 01:49:00.000000000 +0200
++++ dvipdfmx-20090708.new/data/Makefile.am 2009-11-29 23:05:55.000000000 +0100
+@@ -10,7 +10,3 @@
+ mapdatadir = $(datadir)/texmf/fonts/map/dvipdfmx
+ dist_mapdata_DATA = \
+ $(srcdir)/cid-x.map
+-
+-cmapdatadir = $(datadir)/texmf/fonts/cmap/dvipdfmx
+-dist_cmapdata_DATA = \
+- $(srcdir)/EUC-UCS2
diff --git a/app-text/dvipdfmx/metadata.xml b/app-text/dvipdfmx/metadata.xml
new file mode 100644
index 000000000000..084e4884bf3a
--- /dev/null
+++ b/app-text/dvipdfmx/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <herd>tex</herd>
+ <herd>printing</herd>
+ <longdescription lang="en">
+ The DVIPDFMx (formerly dvipdfm-cjk) project provides an eXtended
+ version of the dvipdfm, a DVI to PDF translator developed by Mark A.
+ Wicks. The primary goal of this project is to support multi-byte
+ character encodings and large character sets for East Asian languages
+ by CID-keyed font technology. The secondary goal is to support as
+ many features as pdfTeX developed by Han The Thanh. This project is a
+ combined work of the dvipdfm-jpn project by Shunsaku Hirata and its
+ modified one, dvipdfm-kor, by Jin-Hwan Cho.
+ </longdescription>
+</pkgmetadata>