summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-26 12:01:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-26 12:08:05 -0400
commit0c8142e6999fcf5e0adf16015fec854c42b03e31 (patch)
tree607087043f908a6e8f41976984f9b8813f315912 /app-portage
parentdev-util/github-cli: 2.0.0 bump (diff)
downloadgentoo-0c8142e6999fcf5e0adf16015fec854c42b03e31.tar.gz
gentoo-0c8142e6999fcf5e0adf16015fec854c42b03e31.tar.bz2
gentoo-0c8142e6999fcf5e0adf16015fec854c42b03e31.zip
app-portage/iwdevtools: add 0.3.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.3.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 9b4fac5c6038..40eba0d6f2ac 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,3 +1,4 @@
DIST iwdevtools-0.1.1.tar.gz 16139 BLAKE2B effceb407319d2f8acf44db5642a55c426c73628bef9c2004dd76118dc042cbc1178975e06b14d6950cef417790693af9a98dc77e4873f0175a408ca14f71384 SHA512 b0d3a1145c3ecfc71e7f8b0d8d8e321840869037841e1faa547ad4a385751b4fb13de31b3ed497eeacbdf227a81c4f28ff6fd229b008105489ada7c1a15b88e4
DIST iwdevtools-0.2.0.tar.gz 23498 BLAKE2B 50c946bb69ae720b27836aebb825d6b1e9545e80dda6d0c939c4be7be30f0f4017c309b2794805fc030e074cc2629bbc328545024d5f89860d05693731ab0b55 SHA512 c31d8646477f1cb8ab784441e2f16155248fc337d2138ce6780810dc7e81cdd6792d610db26e8f7759f89f50732c784bf4938c4a861420412f0056fd9b391a08
DIST iwdevtools-0.3.1.tar.gz 25597 BLAKE2B 1129ff57f95c27156023752a85b9cb25f66c75d2548a2d7be284b5de9b2b1dee7ed56fa806d175c7751f29a05529f659de7524f967484deacf9138e83899dd9a SHA512 4504d8fb1ff18497fc747482ab1c707b6c581f6b4ac74a494459e4e5e45867e2ee8e39e60b020225509a6c5654e40b31f17d9de0300a2ef76e9d5df248c01847
+DIST iwdevtools-0.3.2.tar.gz 31510 BLAKE2B 451327cf7b3ed08a9ad0665bd9e3e60beaadc7690f9c0619a02aea1da981102107340b16dfbf95dbfc23797fe5704c1db0f028590714f14848e68ef07897f0f7 SHA512 95deb7d09041f693332ec06897afec7677dddb3d05c2df6d9494a14a484e9a53b51cc2e550a15a039219cdcc238154f1c9a16528d28100659ab87a200a8be344
diff --git a/app-portage/iwdevtools/iwdevtools-0.3.2.ebuild b/app-portage/iwdevtools/iwdevtools-0.3.2.ebuild
new file mode 100644
index 000000000000..c8f5f248d61c
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+BDEPEND="test? ( ${RDEPEND} )"
+
+src_configure() {
+ meson_src_configure -Ddocdir=${PF}
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
+ fi
+}