summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-08 09:59:07 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-08 10:00:01 +0200
commit3bd0382b9dae85f1e8e5365f949435447493b1ce (patch)
tree297b693b4002ef917de85625bb803de0aee6b2c3 /app-pda/libusbmuxd
parentapp-pda/libusbmuxd: drop 2.0.2-r1 (diff)
downloadgentoo-3bd0382b9dae85f1e8e5365f949435447493b1ce.tar.gz
gentoo-3bd0382b9dae85f1e8e5365f949435447493b1ce.tar.bz2
gentoo-3bd0382b9dae85f1e8e5365f949435447493b1ce.zip
app-pda/libusbmuxd: add 2.1.0
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-pda/libusbmuxd')
-rw-r--r--app-pda/libusbmuxd/Manifest1
-rw-r--r--app-pda/libusbmuxd/libusbmuxd-2.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-pda/libusbmuxd/Manifest b/app-pda/libusbmuxd/Manifest
index 3867523c0108..3e11ab998d28 100644
--- a/app-pda/libusbmuxd/Manifest
+++ b/app-pda/libusbmuxd/Manifest
@@ -1 +1,2 @@
DIST libusbmuxd-2.0.2.tar.xz 41960 BLAKE2B 74a031ec595e40cf0532c753553cb2c35785410eba41a0a0abf45ed23dd6af7528238386ee9c0a4f8709cd447192969f15504fcbb58476441dc593ae28c388d9 SHA512 ce940fc6741973ed09ff0e5428aef78577449ca8e13766e9cbe121f3a2a26873ca164f10b441cc046653cc8550b68cc869ecb57a50fc999cebb55702642c4766
+DIST libusbmuxd-2.1.0.tar.bz2 325055 BLAKE2B f027a3d5fe7cae4628f2120f2c47b66928d4c426848e925ed3cf9ad22f8da23c7fb3a8c9588bc1576a797ac1b8f523455f46b94ce453c8e894da16e06c6bb05a SHA512 c7646b8c7e6c55bb87595380d22d77563f9d3981bf8f169a7ac85650e2860bcbb6831c4968040b92efdc1267a8ca9ae81c2f46c6644ba0c40333f81d6651cf19
diff --git a/app-pda/libusbmuxd/libusbmuxd-2.1.0.ebuild b/app-pda/libusbmuxd/libusbmuxd-2.1.0.ebuild
new file mode 100644
index 000000000000..5221189169b4
--- /dev/null
+++ b/app-pda/libusbmuxd/libusbmuxd-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+" # tools/*.c is GPL-2+, rest is LGPL-2.1+
+SLOT="0/2.0-7" # based on SONAME of libusbmuxd-2.0.so
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+
+RDEPEND="
+ >=app-pda/libimobiledevice-glue-1.2.0:=
+ >=app-pda/libplist-2.2.0:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(usex kernel_linux '' --without-inotify)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}