summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-06-20 18:30:47 +0300
committerPacho Ramos <pacho@gentoo.org>2024-07-05 19:03:35 +0200
commitf5c49397c9a14102389f766256d8a8b29bd5cb48 (patch)
treebfbd0c37c90202174490030f6c820d0da7defd48 /app-office
parentnet-im/neochat: Disable broken texthandlertest (diff)
downloadgentoo-f5c49397c9a14102389f766256d8a8b29bd5cb48.tar.gz
gentoo-f5c49397c9a14102389f766256d8a8b29bd5cb48.tar.bz2
gentoo-f5c49397c9a14102389f766256d8a8b29bd5cb48.zip
app-office/onlyoffice-bin: add 8.1.0
Closes: https://bugs.gentoo.org/935510 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/onlyoffice-bin/Manifest1
-rw-r--r--app-office/onlyoffice-bin/onlyoffice-bin-8.1.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-office/onlyoffice-bin/Manifest b/app-office/onlyoffice-bin/Manifest
index 4fdd747bf8a6..ce1066f6933e 100644
--- a/app-office/onlyoffice-bin/Manifest
+++ b/app-office/onlyoffice-bin/Manifest
@@ -1 +1,2 @@
DIST onlyoffice-bin-8.0.1_amd64.deb 208469572 BLAKE2B 95f2e9df7c5673aa6edbb682078a9c133f1a5925dd1a84d3342c34cbe6a07691f4f5f425c264cf7760ae063a828caf1792533da1eb59423c48c77119935c889a SHA512 a16c784f1c9f056a2ed09fecff2cf7a4e2206006e04a1f8d8e260aeddd6b2195b0bbadd9f3b71a454d55311978d16d945cd345938688cf7e37aa9f11967c572f
+DIST onlyoffice-bin-8.1.0_amd64.deb 208372598 BLAKE2B 9483c652429a61a87a20f95352db34dc176c65d60f7aef45738e4f7175cb5c6a39c918133c488d6f7bae1bdf2677235f0053f53b11e890717670869e4742d088 SHA512 f755ca7b29cdce3c520cf0ccb386f8be2be229989f6c6baba51b5741d6969ba3f101463f1f4aeb9c7a4cfc8e6d592c3f90c3ad19277ea3e6218a3c87ce6ddd42
diff --git a/app-office/onlyoffice-bin/onlyoffice-bin-8.1.0.ebuild b/app-office/onlyoffice-bin/onlyoffice-bin-8.1.0.ebuild
new file mode 100644
index 000000000000..a284a31d72eb
--- /dev/null
+++ b/app-office/onlyoffice-bin/onlyoffice-bin-8.1.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_P="ONLYOFFICE-DesktopEditors-"${PV}""
+
+DESCRIPTION="Onlyoffice is an office productivity suite (binary version)"
+HOMEPAGE="https://www.onlyoffice.com/"
+SRC_URI="
+ amd64? (
+ https://github.com/ONLYOFFICE/DesktopEditors/releases/download/v"${PV}"/onlyoffice-desktopeditors_amd64.deb
+ -> "${P}"_amd64.deb
+ )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip test"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5[eglfs]
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/libglvnd
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-devel/gcc
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ || (
+ media-libs/libpulse
+ media-sound/apulse
+ )
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Allow launching the ONLYOFFICE on ALSA systems via
+ # media-sound/apulse
+ sed -i -e 's|\(export LD_LIBRARY_PATH=$DIR$LDLPATH\)|\1:'"${EPREFIX}"'/usr/'$(get_libdir)'/apulse|' \
+ "${S}"/usr/bin/onlyoffice-desktopeditors || die
+}
+
+src_install() {
+ domenu usr/share/applications/onlyoffice-desktopeditors.desktop
+ for size in {16,24,32,48,64,128,256}; do
+ newicon -s "${size}" opt/onlyoffice/desktopeditors/asc-de-"${size}".png onlyoffice-desktopeditors.png
+ done
+
+ dobin usr/bin/desktopeditors usr/bin/onlyoffice-desktopeditors
+ doins -r opt
+ fperms +x /opt/onlyoffice/desktopeditors/{DesktopEditors,editors_helper,converter/x2t}
+}