summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-09-14 16:57:08 +0200
committerHanno <hanno@gentoo.org>2016-09-14 16:57:08 +0200
commit8cfa6a9aa00bc93070675b02b46154a2a049d39f (patch)
tree22ba220aa6879d2f1e45aad715ff65850b9f7da4 /app-office/geierlein/geierlein-0.9.5.ebuild
parentdev-util/debhelper: Old. (diff)
downloadgentoo-8cfa6a9aa00bc93070675b02b46154a2a049d39f.tar.gz
gentoo-8cfa6a9aa00bc93070675b02b46154a2a049d39f.tar.bz2
gentoo-8cfa6a9aa00bc93070675b02b46154a2a049d39f.zip
app-office/geierlein: version bump to 0.9.5
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-office/geierlein/geierlein-0.9.5.ebuild')
-rw-r--r--app-office/geierlein/geierlein-0.9.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-office/geierlein/geierlein-0.9.5.ebuild b/app-office/geierlein/geierlein-0.9.5.ebuild
new file mode 100644
index 000000000000..c38a69fa21e0
--- /dev/null
+++ b/app-office/geierlein/geierlein-0.9.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Submit tax forms (Umsatzsteuervoranmeldung) to German ELSTER"
+HOMEPAGE="https://stesie.github.com/geierlein/"
+SRC_URI="https://github.com/stesie/geierlein/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="|| ( www-client/firefox www-client/firefox-bin )"
+DEPEND=""
+
+# needs nodejs and a couple of modules we don't have packaged
+RESTRICT="test"
+
+src_compile() {
+ emake prefix=/usr
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ install || die
+ dodoc README.md
+}