summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ytree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ytree')
-rw-r--r--app-misc/ytree/Manifest2
-rw-r--r--app-misc/ytree/files/ytree-1.94-bindir.patch11
-rw-r--r--app-misc/ytree/metadata.xml7
-rw-r--r--app-misc/ytree/ytree-1.97.ebuild35
-rw-r--r--app-misc/ytree/ytree-1.98.ebuild35
5 files changed, 90 insertions, 0 deletions
diff --git a/app-misc/ytree/Manifest b/app-misc/ytree/Manifest
new file mode 100644
index 000000000000..8e9d38cfcc09
--- /dev/null
+++ b/app-misc/ytree/Manifest
@@ -0,0 +1,2 @@
+DIST ytree-1.97.tar.gz 121571 SHA256 9db152524d08ec0d61b2b83a37435c5e77ebfc4b21f973fddfb571beb445a60d SHA512 30054868149071426944eb46bb2815a579d2212dcbd25faa0fe574cd28102cc0d57993954b9e55c0e1a8b6afe5492d25749a4ab5790d5c6b1630e965a2f39096 WHIRLPOOL ed58b5c68c17b573c02735626579d2dfb36ca2c59589a152c08b12497f772b92e054a8e903e85c4aaf7c39b18a7f75842f9b4e989180f2f3bbe8619e1ed5ca23
+DIST ytree-1.98.tar.gz 122610 SHA256 e7264e1c112bf62aba1f6ed0078308930cd8f01317a157ed1718b8dac09195c5 SHA512 b75f3b04af72270e2b4db6dc7448435fdf2d197d98bd2f4fdf6d3131091c8c3a697f8b0cabc1625502c616cee4e27ae6aa6fa2bfc082beeae1b6ecad9921dbef WHIRLPOOL 292da20c8c918eb468ccab6d0a5e09ecef8c44dad990326e2366eac81f11c039d1461308b053b54d751a7fb883dac9dda28d6abe6d12f2682c4b58dc58390665
diff --git a/app-misc/ytree/files/ytree-1.94-bindir.patch b/app-misc/ytree/files/ytree-1.94-bindir.patch
new file mode 100644
index 000000000000..a79904e923b3
--- /dev/null
+++ b/app-misc/ytree/files/ytree-1.94-bindir.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig 2010-04-11 17:44:57.511131862 +0200
++++ ./Makefile 2010-04-11 17:44:14.143178887 +0200
+@@ -225,6 +225,8 @@
+ $(CC) $(LFLAGS) -o $@ $(OBJS) $(LDFLAGS)
+
+ install: $(MAIN)
++ if [ ! -d $(BINDIR) ]; then mkdir -p $(BINDIR); fi
++ if [ ! -d $(MANDIR) ]; then mkdir -p $(MANDIR); fi
+ install $(MAIN) $(BINDIR)
+ gzip -9c ytree.1 > ytree.1.gz
+ if [ -d $(MANDIR) ]; then install -m 0644 ytree.1.gz $(MANDIR)/; fi
diff --git a/app-misc/ytree/metadata.xml b/app-misc/ytree/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/app-misc/ytree/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/ytree/ytree-1.97.ebuild b/app-misc/ytree/ytree-1.97.ebuild
new file mode 100644
index 000000000000..d44d09a1b996
--- /dev/null
+++ b/app-misc/ytree/ytree-1.97.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A (curses-based) file manager"
+HOMEPAGE="http://www.han.de/~werner/ytree.html"
+SRC_URI="http://www.han.de/~werner/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/readline
+ sys-libs/ncurses
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.94-bindir.patch
+}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}usr" install || die "emake install failed"
+ dodoc ytree.conf
+}
diff --git a/app-misc/ytree/ytree-1.98.ebuild b/app-misc/ytree/ytree-1.98.ebuild
new file mode 100644
index 000000000000..630402351e90
--- /dev/null
+++ b/app-misc/ytree/ytree-1.98.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A (curses-based) file manager"
+HOMEPAGE="http://www.han.de/~werner/ytree.html"
+SRC_URI="http://www.han.de/~werner/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/readline
+ sys-libs/ncurses
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.94-bindir.patch
+}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}usr" install
+ dodoc CHANGES README THANKS ytree.conf
+}