summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-09-25 09:18:53 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-09-25 09:18:53 -0700
commit31d1b17a6ea50e303814f9589e5f04a78420cdb6 (patch)
treecd361eb21f3b3440ae3a36de7a47519bff278ff6 /app-misc/tmuxp
parentmedia-libs/waffle: Version bump to 1.8.0 (diff)
downloadgentoo-31d1b17a6ea50e303814f9589e5f04a78420cdb6.tar.gz
gentoo-31d1b17a6ea50e303814f9589e5f04a78420cdb6.tar.bz2
gentoo-31d1b17a6ea50e303814f9589e5f04a78420cdb6.zip
app-misc/tmuxp: add 1.31.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.31.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 54b92dc1f0eb..344e19eef370 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -1,3 +1,4 @@
DIST tmuxp-1.27.0.tar.gz 862056 BLAKE2B baad339bc59498d26911507f29de38d55991515e03123edc8dca10159fed1492c1ffe37cf45d6d04ffc73134e0ee312c0ace2ffc53ba9cae258239746169e416 SHA512 a9c450c40a40c284c609011d5e47b12ed1a9b1d5c4036b887df7fd75a3bb6263847c459a7e61fc9dcdb463a3ac20de6ac9038b1559369a5f36641ab0baee755d
DIST tmuxp-1.27.1.tar.gz 861380 BLAKE2B b57d7f4f5c23d1df71abd310b02535c8da7971df4473a3ff2c5feffb2967bd7b0c00e47e45bc04bf56b9503d17b55786b9abfeabec4f6d33989a2f58c5ba49d5 SHA512 3e3d9405a77fe03d2a249bad4ef215982d9135e85dc58899a337d0a3f6d76a4e9f155f5dc37993f5e57955411928ce921ce1c1f1ee7c39f0939d2831a3d600be
DIST tmuxp-1.30.1.tar.gz 862947 BLAKE2B b80c85df49c267a076d4f073bb83e4b0823ec140324e5689c0300dc2a854c03cb313544b2265ac84b2ac6bd8253b30bfec2cfed568311274fd65fa68221d9c9e SHA512 b9eca20dce6aa6a61807225a40a343d01d3ce767c613c8d98eec25c6037bde1b4859abfd3ac43c2f7843316c2beb995d68e4c4af9d4949e854da4b71919106e8
+DIST tmuxp-1.31.0.tar.gz 862999 BLAKE2B 56634c8686701d6081db19bf659012df54f4b393fc60dc085c4bd1c460e85d8910ce55651bc6207c4c72b5c8a4c78548145c4b8076bd674942f3e72b67b0edae SHA512 32ea719798ca16d55090ab8ea3e54b03e9136b7bcd4b9c74f77c73c703479a435468f31b1761855b17710c5df9eadde094d56166698217f1ffd6efba42607824
diff --git a/app-misc/tmuxp/tmuxp-1.31.0.ebuild b/app-misc/tmuxp/tmuxp-1.31.0.ebuild
new file mode 100644
index 000000000000..f94c581b9756
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.31.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.23.2*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}