summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tdl/tdl-1.5.2-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tdl/tdl-1.5.2-r2.ebuild')
-rw-r--r--app-misc/tdl/tdl-1.5.2-r2.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/app-misc/tdl/tdl-1.5.2-r2.ebuild b/app-misc/tdl/tdl-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..5fb37d220f2f
--- /dev/null
+++ b/app-misc/tdl/tdl-1.5.2-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Command line To Do List manager"
+HOMEPAGE="http://www.rc0.org.uk/tdl/"
+SRC_URI="
+ http://www.rpcurnow.force9.co.uk/tdl/${P}.tar.gz
+ http://dev.gentoo.org/~jlec/distfiles/${PN}-screenshot.png.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc readline"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-apps/texinfo
+ doc? ( virtual/texi2dvi )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${P}-list.c.patch \
+ "${FILESDIR}"/${P}-main.c.patch \
+ "${FILESDIR}"/${P}-man.patch
+
+ tc-export CC
+}
+
+src_configure() {
+ local myconf="--prefix=${EPREFIX}/usr"
+
+ if ! use readline; then
+ myconf="${myconf} --without-readline"
+
+ sed -i 's#\($(LIB_READLINE)\)#\1 -lncurses##g' "${S}"/Makefile.in || die
+ fi
+ sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure || die
+
+ # XXX: do not replace with econf.
+ "${S}"/configure ${myconf} || die "configure failed, sorry!"
+}
+
+src_compile() {
+ emake all tdl.info tdl.html tdl.txt
+ use doc && emake tdl.dvi tdl.ps tdl.pdf
+}
+
+src_install() {
+ local i
+
+ dodoc README NEWS tdl.txt "${WORKDIR}"/screenshot.png
+ doinfo tdl.info
+ dohtml tdl.html
+
+ dobin tdl
+ doman tdl.1
+
+ for i in tdl{a,l,d,g}
+ do
+ dosym tdl /usr/bin/${i}
+ dosym tdl.1 /usr/share/man/man1/${i}.1
+ done
+
+ if use doc; then
+ dodoc tdl.dvi tdl.ps tdl.pdf
+ fi
+}