summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ranger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ranger')
-rw-r--r--app-misc/ranger/Manifest1
-rw-r--r--app-misc/ranger/files/ranger-1.6.1-w3mimgdisplay.patch11
-rw-r--r--app-misc/ranger/metadata.xml15
-rw-r--r--app-misc/ranger/ranger-1.7.1.ebuild38
-rw-r--r--app-misc/ranger/ranger-9999.ebuild31
5 files changed, 96 insertions, 0 deletions
diff --git a/app-misc/ranger/Manifest b/app-misc/ranger/Manifest
new file mode 100644
index 000000000000..2e8fbe7e737b
--- /dev/null
+++ b/app-misc/ranger/Manifest
@@ -0,0 +1 @@
+DIST ranger-1.7.1.tar.gz 266089 SHA256 f8b06135165142508ae7ec22ab2c95f6e51b4018c645d11226086d4c45b7df86 SHA512 646e2e4286813085820f35d5dfb6528ed1005e833db92d0521164c067aed2bdf56f4d3acc7ef77388e54a7f7191608e390b65305f62fed39b4109e3fff27f410 WHIRLPOOL 4b9dae8bc99ab4a310d0d71e7793b2cdd21e4146f389b02f8a1496f8f1bae4015a31e9d4de993720297139ac7a377d6673f4eea1250d802298c076769fedfc18
diff --git a/app-misc/ranger/files/ranger-1.6.1-w3mimgdisplay.patch b/app-misc/ranger/files/ranger-1.6.1-w3mimgdisplay.patch
new file mode 100644
index 000000000000..3e11c33a697e
--- /dev/null
+++ b/app-misc/ranger/files/ranger-1.6.1-w3mimgdisplay.patch
@@ -0,0 +1,11 @@
+--- ranger-1.6.1/ranger/ext/img_display.py
++++ ranger-1.6.1/ranger/ext/img_display.py
+@@ -13,7 +13,7 @@
+ import termios, fcntl, struct, sys, os
+ from subprocess import Popen, PIPE
+
+-W3MIMGDISPLAY_PATH = '/usr/lib/w3m/w3mimgdisplay'
++W3MIMGDISPLAY_PATH = '/usr/libexec/w3m/w3mimgdisplay'
+ W3MIMGDISPLAY_OPTIONS = []
+
+ class ImgDisplayUnsupportedException(Exception):
diff --git a/app-misc/ranger/metadata.xml b/app-misc/ranger/metadata.xml
new file mode 100644
index 000000000000..5cb9dc86a6f5
--- /dev/null
+++ b/app-misc/ranger/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ranger is a console file manager that gives you greater flexibility and a
+ good overview of your files without having to leave your console. It
+ visualizes the directory tree in two dimensions: the directory hierarchy on
+ one, lists of files on the other, with a preview to the right so you know
+ where you'll be going.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/ranger/ranger-1.7.1.ebuild b/app-misc/ranger/ranger-1.7.1.ebuild
new file mode 100644
index 000000000000..5653d30e82f1
--- /dev/null
+++ b/app-misc/ranger/ranger-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/ranger.git"
+ inherit git-r3
+else
+ SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 ~ppc x86"
+fi
+
+DESCRIPTION="A vim-inspired file manager for the console"
+HOMEPAGE="http://ranger.nongnu.org/"
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="virtual/pager"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-w3mimgdisplay.patch )
+
+src_prepare() {
+ sed -i "s|share/doc/ranger|share/doc/${PF}|" setup.py doc/ranger.1 || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Ranger has many optional dependencies to support enhanced file previews."
+ elog "See the README or homepage for more details."
+ fi
+}
diff --git a/app-misc/ranger/ranger-9999.ebuild b/app-misc/ranger/ranger-9999.ebuild
new file mode 100644
index 000000000000..8c5d92b4b0d9
--- /dev/null
+++ b/app-misc/ranger/ranger-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/ranger.git"
+ inherit git-r3
+else
+ SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A vim-inspired file manager for the console"
+HOMEPAGE="http://ranger.nongnu.org/"
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="virtual/pager"
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Ranger has many optional dependencies to support enhanced file previews."
+ elog "See the README or homepage for more details."
+ fi
+}