summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Herdiansyah <herdiansyah@openmailbox.org>2017-01-23 18:25:49 +0700
committerPatrice Clement <monsieurp@gentoo.org>2017-01-26 00:28:44 +0100
commit03b700eaed343726bc0c05d18574e57ab851ce17 (patch)
treecd4b107a6673de2594a400159e955231bd28908e /app-misc/neofetch/neofetch-3.0.ebuild
parentapp-portage/portpeek: Fix for bug #606092, thanks to Derk for reporting and B... (diff)
downloadgentoo-03b700eaed343726bc0c05d18574e57ab851ce17.tar.gz
gentoo-03b700eaed343726bc0c05d18574e57ab851ce17.tar.bz2
gentoo-03b700eaed343726bc0c05d18574e57ab851ce17.zip
app-misc/neofetch: version bump to 3.0.
Closes: https://github.com/gentoo/gentoo/pull/3605
Diffstat (limited to 'app-misc/neofetch/neofetch-3.0.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/neofetch/neofetch-3.0.ebuild b/app-misc/neofetch/neofetch-3.0.ebuild
new file mode 100644
index 000000000000..9a4c4fa719e6
--- /dev/null
+++ b/app-misc/neofetch/neofetch-3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="sys-apps/pciutils
+ X? (
+ x11-apps/xprop
+ x11-apps/xwininfo
+ x11-apps/xrandr
+ www-client/w3m[imlib]
+ media-libs/imlib2
+ media-gfx/imagemagick
+ )"
+
+pkg_postinst() {
+ ewarn "A lot of things have changed in neofetch 3.0, and we cannot"
+ ewarn "guarantee that your config will work in neofetch 3.0. As such,"
+ ewarn "we recommend you to use a new config. You can delete your current"
+ ewarn "config from $HOME/.config/neofetch"
+
+ einfo "The system-wide config has been moved from /usr/share/neofetch/config"
+ einfo "to /etc/neofetch/config."
+}