summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/fslint/fslint-2.44-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/fslint/fslint-2.44-r2.ebuild')
-rw-r--r--app-misc/fslint/fslint-2.44-r2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/fslint/fslint-2.44-r2.ebuild b/app-misc/fslint/fslint-2.44-r2.ebuild
new file mode 100644
index 000000000000..41a66000f63c
--- /dev/null
+++ b/app-misc/fslint/fslint-2.44-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="A utility to find various forms of lint on a filesystem"
+HOMEPAGE="http://www.pixelbeat.org/fslint/"
+SRC_URI="http://www.pixelbeat.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+IUSE="nls"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ gnome-base/libglade:2.0"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext:* )"
+
+src_prepare() {
+ # Change some paths to make ${PN}-gui run when installed in /usr/bin.
+ sed -e "s:^liblocation=.*$:liblocation='${EROOT}usr/share/${PN}' #Gentoo:" \
+ -e "s:^locale_base=.*$:locale_base=None #Gentoo:" \
+ -i ${PN}-gui || die
+}
+
+src_install() {
+ share=/usr/share/${PN}
+
+ insinto ${share}
+ doins ${PN}{.glade,.gladep,_icon.png}
+
+ exeinto ${share}/${PN}
+ doexe ${PN}/find*
+ doexe ${PN}/${PN}
+ doexe ${PN}/zipdir
+
+ exeinto ${share}/${PN}/fstool/
+ doexe ${PN}/fstool/*
+
+ exeinto ${share}/${PN}/supprt/
+ doexe ${PN}/supprt/{fslver,getffl,getffp,getfpf,md5sum_approx}
+
+ exeinto ${share}/${PN}/supprt/rmlint
+ doexe ${PN}/supprt/rmlint/*
+
+ dobin ${PN}-gui
+
+ doicon ${PN}_icon.png
+ domenu ${PN}.desktop
+
+ dodoc doc/{FAQ,NEWS,README,TODO}
+ doman man/${PN}{.1,-gui.1}
+
+ if use nls ; then
+ cd po
+ emake DESTDIR="${D}" install
+ fi
+
+ # Fix Python shebangs.
+ python_replicate_script "${ED}"${share}/${PN}/fstool/dupwaste
+ python_replicate_script "${ED}"${share}/${PN}/supprt/md5sum_approx
+ python_replicate_script "${ED}"${share}/${PN}/supprt/rmlint/merge_hardlinks
+ python_replicate_script "${ED}"${share}/${PN}/supprt/rmlint/fixdup
+ python_replicate_script "${ED}"/usr/bin/${PN}-gui
+}