summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ddccontrol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ddccontrol')
-rw-r--r--app-misc/ddccontrol/Manifest1
-rw-r--r--app-misc/ddccontrol/ddccontrol-0.4.2_p20140105-r1.ebuild77
-rw-r--r--app-misc/ddccontrol/metadata.xml14
3 files changed, 92 insertions, 0 deletions
diff --git a/app-misc/ddccontrol/Manifest b/app-misc/ddccontrol/Manifest
new file mode 100644
index 000000000000..118397b40828
--- /dev/null
+++ b/app-misc/ddccontrol/Manifest
@@ -0,0 +1 @@
+DIST ddccontrol-0.4.2_p20140105.tar.gz 177771 SHA256 14026465b1c1b3bd0fecfe3f199139f1365317a0974844c82aa783f2125e064c SHA512 7a28e9b81ee14e0431c57d372c8d43f861f61c35b441111e1f42d1aa62c333b0cc6a101dcb39d30e9661aaa85a02d755e4adef3a9b20a6952e1599e3ac12c72f WHIRLPOOL 55083597ab4e7e78d5315f114b257f3bfbadd1712ad5bd27e88d3b18ca694554ec51542b2b9a88bd7e21ffbdc7d4f82b80f1d43b5f16f90bdcc2edfb2421c7a6
diff --git a/app-misc/ddccontrol/ddccontrol-0.4.2_p20140105-r1.ebuild b/app-misc/ddccontrol/ddccontrol-0.4.2_p20140105-r1.ebuild
new file mode 100644
index 000000000000..770e66766904
--- /dev/null
+++ b/app-misc/ddccontrol/ddccontrol-0.4.2_p20140105-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="DDCControl allows control of monitor parameters via DDC"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+COMMIT_ID="9d89d8c0b959a4da62ecc50fb2aeb23142d4bfb4"
+SRC_URI="https://github.com/ddccontrol/ddccontrol/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc gtk nls +pci static-libs video_cards_fglrx"
+S=${WORKDIR}/${PN}-${COMMIT_ID}
+
+RDEPEND="app-misc/ddccontrol-db
+ dev-libs/libxml2:2
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pci? ( sys-apps/pciutils )
+ video_cards_fglrx? ( x11-libs/amd-adl-sdk )"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser
+ dev-util/intltool
+ sys-kernel/linux-headers
+ doc? (
+ >=app-text/docbook-xsl-stylesheets-1.65.1
+ >=dev-libs/libxslt-1.1.6
+ app-text/htmltidy
+ )"
+
+src_prepare() {
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467574
+ sed -i '/;Application/d' src/gddccontrol/gddccontrol.desktop.in || die
+
+ # ppc/ppc64 do not have inb/outb/ioperm
+ # they also do not have (sys|asm)/io.h
+ if ! use amd64 && ! use x86 ; then
+ local card
+ for card in sis intel810 ; do
+ sed -r -i \
+ -e "/${card}.Po/d" \
+ -e "s~${card}[^[:space:]]*~ ~g" \
+ src/ddcpci/Makefile.{am,ini} || die
+ done
+ sed -i \
+ -e '/sis_/d' \
+ -e '/i810_/d' \
+ src/ddcpci/main.c || die
+ fi
+
+ ## Save for a rainy day or future patching
+ touch config.rpath ABOUT-NLS
+ eautoreconf
+ intltoolize --force || die "intltoolize failed"
+}
+
+src_configure() {
+ econf \
+ --htmldir='$(datarootdir)'/doc/${PF}/html \
+ --disable-gnome-applet \
+ $(use_enable doc) \
+ $(use_enable gtk gnome) \
+ $(use_enable nls) \
+ $(use_enable pci ddcpci) \
+ $(use_enable static-libs static) \
+ $(use_enable video_cards_fglrx amdadl)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/app-misc/ddccontrol/metadata.xml b/app-misc/ddccontrol/metadata.xml
new file mode 100644
index 000000000000..74cde140509e
--- /dev/null
+++ b/app-misc/ddccontrol/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <use>
+ <flag name="pci">enable direct PCI memory access (the setuid ddcpci util)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ddccontrol/ddccontrol</remote-id>
+ </upstream>
+</pkgmetadata>