summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-16 19:28:16 +0200
committerSam James <sam@gentoo.org>2022-10-17 22:50:42 +0100
commit7e92c72808aef5206a53031354358665a3918b15 (patch)
treeeef828bb14fd2a54d7e8e8ec1ad063dd250bc1db /app-misc/boxes
parentnet-misc/whois: add 5.5.14 (diff)
downloadgentoo-7e92c72808aef5206a53031354358665a3918b15.tar.gz
gentoo-7e92c72808aef5206a53031354358665a3918b15.tar.bz2
gentoo-7e92c72808aef5206a53031354358665a3918b15.zip
app-misc/boxes: new version 2.2.0, patched ebuild to work with clang16
Closes: https://bugs.gentoo.org/875707 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/27804 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/boxes')
-rw-r--r--app-misc/boxes/Manifest1
-rw-r--r--app-misc/boxes/boxes-2.2.0.ebuild42
-rw-r--r--app-misc/boxes/files/boxes-2.2.0-fix-clang16-build.patch15
3 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/boxes/Manifest b/app-misc/boxes/Manifest
index f012be435aae..2549560e3978 100644
--- a/app-misc/boxes/Manifest
+++ b/app-misc/boxes/Manifest
@@ -1 +1,2 @@
DIST boxes-1.1.2.tar.gz 101658 BLAKE2B 002cd1a458d39069cf0955fc37c05e60590003ac987619d89851b3943cdaca986b57e631081a196e7c9a2a245397e72f8c882fb6e190c0127289602ead223a7b SHA512 10efb5f62d94003532e2f32d6a0f7c76dd86c7cfaf150f35c24516dc6684f5e3909ecd5fd48c1c64f25f874cb1364bdf3d959a2fb837bfe74c2d879a35f443dd
+DIST boxes-2.2.0.tar.gz 230099 BLAKE2B 4adb8ddde85cb31f32e98916d5ea2a57afcaa0470f796ba296cb3b80780f158a24b2bc5e9ba923b6a3b35b8f7781cd6ddacd89abadf6f2c07549be7ffe1458f4 SHA512 534d441c34316572d0c7e89f343a3bc5bb5a8466e4d4ed703fb2d14b714f5a6b224f7b0d408525d492da4610f9c5ffd8508e16d98a0781897567fb4aeb316f39
diff --git a/app-misc/boxes/boxes-2.2.0.ebuild b/app-misc/boxes/boxes-2.2.0.ebuild
new file mode 100644
index 000000000000..bb96df727114
--- /dev/null
+++ b/app-misc/boxes/boxes-2.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="https://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
+SRC_URI="https://github.com/ascii-boxes/boxes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-libs/libpcre2[pcre32]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-clang16-build.patch" )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:STRIP=true:STRIP=false:g' \
+ -i src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS_ADDTL="${CFLAGS}" LDFLAGS_ADDTL="${LDFLAGS}"
+}
+
+src_install() {
+ dobin out/boxes
+ doman doc/boxes.1
+ insinto /usr/share
+ newins boxes-config boxes
+ einstalldocs
+}
diff --git a/app-misc/boxes/files/boxes-2.2.0-fix-clang16-build.patch b/app-misc/boxes/files/boxes-2.2.0-fix-clang16-build.patch
new file mode 100644
index 000000000000..38be8e1ede81
--- /dev/null
+++ b/app-misc/boxes/files/boxes-2.2.0-fix-clang16-build.patch
@@ -0,0 +1,15 @@
+change function prototype to work with c2x standard. Build fails with clang16 without this
+
+See: https://github.com/ascii-boxes/boxes/issues/106
+
+--- a/src/remove.h
++++ b/src/remove.h
+@@ -22,7 +22,7 @@
+
+
+ int remove_box();
+-void output_input();
++void output_input(const int trim_only);
+
+
+ #endif /*REMOVE_H*/