summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/activylircd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/activylircd')
-rw-r--r--app-misc/activylircd/Manifest1
-rw-r--r--app-misc/activylircd/activylircd-0.4.ebuild34
-rw-r--r--app-misc/activylircd/files/activylircd-0.4-linking.patch25
-rw-r--r--app-misc/activylircd/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/app-misc/activylircd/Manifest b/app-misc/activylircd/Manifest
new file mode 100644
index 000000000000..1b0c4d31e413
--- /dev/null
+++ b/app-misc/activylircd/Manifest
@@ -0,0 +1 @@
+DIST activylircd-0.4.tgz 26900 SHA256 d9475ca9009d0af83c1c88352b0aba39a485dd4b469950fbc005010f6e966d3f SHA512 2440f4b858d945ae7103d14d6aeea6e16461713da60eaadc0767843d218d12554efc99607231503aabcbb853cd26cd205c4c783083b7c77d6d3a5e3f9cbd2cb7 WHIRLPOOL 4dc995d80e189b2093aec1f9fb18328990048c38131c5a77d4331fccfc99b75e347c0170da854869697b7653f2e98f300c5aadb6eea05054c263cbcb2549c1cf
diff --git a/app-misc/activylircd/activylircd-0.4.ebuild b/app-misc/activylircd/activylircd-0.4.ebuild
new file mode 100644
index 000000000000..5e1f745552f4
--- /dev/null
+++ b/app-misc/activylircd/activylircd-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ACTIVYLIRCD lirc daemon for activy remote control"
+HOMEPAGE="http://www.htpc-forum.de/"
+SRC_URI="http://www.htpc-forum.de/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-linking.patch" # Bug #277656
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin activylircd
+ dobin key2xd eventmapper key2lircd key2xd
+ dodoc key2x.conf README
+}
diff --git a/app-misc/activylircd/files/activylircd-0.4-linking.patch b/app-misc/activylircd/files/activylircd-0.4-linking.patch
new file mode 100644
index 000000000000..8ebd721fd38e
--- /dev/null
+++ b/app-misc/activylircd/files/activylircd-0.4-linking.patch
@@ -0,0 +1,25 @@
+Index: activylircd-0.4/Makefile
+===================================================================
+--- activylircd-0.4.orig/Makefile
++++ activylircd-0.4/Makefile
+@@ -14,16 +14,16 @@ names.h: /usr/include/linux/input.h genn
+ ./gennames $< > $@
+
+ activylircd: activylircd.c /usr/include/linux/input.h names.h Makefile
+- $(CC) $(CFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ key2lircd: key2lircd.c /usr/include/linux/input.h names.h Makefile
+- $(CC) $(CFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ eventmapper: eventmapper.c /usr/include/linux/input.h names.h Makefile
+- $(CC) $(CFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ key2xd: key2xd.c Makefile
+- $(CC) $(CFLAGS) -o $@ -lX11 -lXtst $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< -lX11 -lXtst
+
+ install: $(PROG)
+ install -v -t /usr/bin $(PROG)
diff --git a/app-misc/activylircd/metadata.xml b/app-misc/activylircd/metadata.xml
new file mode 100644
index 000000000000..332e9ad12d8a
--- /dev/null
+++ b/app-misc/activylircd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>vdr@helmutauer.de</email>
+ <name>Helmut Auer</name>
+ <description>Proxy maintaining through zzam</description>
+</maintainer>
+</pkgmetadata>