summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-01-15 21:28:06 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-01-15 21:28:06 +0900
commit2044b7e7215e16438e7c76f58de7735d8ef68081 (patch)
treee8c475144a0cee85a1c99a6a513992e564741a84 /app-i18n
parentdev-libs/libatomic_ops: Stabilize 7.8.2 sparc, #922156 (diff)
downloadgentoo-2044b7e7215e16438e7c76f58de7735d8ef68081.tar.gz
gentoo-2044b7e7215e16438e7c76f58de7735d8ef68081.tar.bz2
gentoo-2044b7e7215e16438e7c76f58de7735d8ef68081.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.11.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 3d06692a6264..10a4c3d66386 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
+DIST ibus-typing-booster-2.24.11.tar.gz 12321813 BLAKE2B 3757d6d43fb0837c10ad4641f72a3f09f2664e78905ebf98a36f723c07a43e1de85fd916a5c24aa13806d093a87d673f585234a36b4d8fc7cc8c8fc1a8d5d2d9 SHA512 9cc906061aaa8e4720e48296158c990b2411aad26f0ebf71e58bc202b2470d100541174e4e007c55e89c9b7540e21ef9107045dcff0e86ffba30cfd9acded989
DIST ibus-typing-booster-2.24.4.tar.gz 12217171 BLAKE2B 945caad00067dfcb25b6a0249e3b8c1ff18e4880b046768a2b7bf6506f6ca54e63c178d296cd6daf17e01fd7714fd9b8336c91dfe0b5161503307a5a80956009 SHA512 a6baa0bb7c5a3124dcb017d218d602035b21b6bb7a3cf34c229e265dd4d970677a99ef4d473e39b7efad65248e1398af8c47a5cf05225b7bcff293a2fe9570cf
DIST ibus-typing-booster-2.24.5.tar.gz 12217369 BLAKE2B d371dfdcced114c389a2766e3ede367550ba0c238a438d13cd48ee29d68f39296b57620ee9f6964abb1893240fa72f141a104c43a87a49c011e7e3b73dfe5461 SHA512 8ed58334ce044a19b802c11e3a99ab7bdf31c1e86f1aa4cefd6cd66c3001f9c25b333ad19d1c36cd09982513b124cbb2f39ed2832ee262001abd6f0997abfc84
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.11.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.11.ebuild
new file mode 100644
index 000000000000..95f8e650235b
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}