summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-19 23:30:06 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-19 23:39:58 +0900
commit928f3c32332c610c4e13854bdaa4e00b500b8c9a (patch)
treeb2c13a936a480cd4a663a58bc0f540fe3494eedb /app-i18n/ibus-table
parentapp-i18n/ibus-table: update to EAPI 7 (diff)
downloadgentoo-928f3c32332c610c4e13854bdaa4e00b500b8c9a.tar.gz
gentoo-928f3c32332c610c4e13854bdaa4e00b500b8c9a.tar.bz2
gentoo-928f3c32332c610c4e13854bdaa4e00b500b8c9a.zip
app-i18n/ibus-table: use xdg eclass
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/ibus-table-1.9.18-r2.ebuild (renamed from app-i18n/ibus-table/ibus-table-1.9.18-r1.ebuild)14
-rw-r--r--app-i18n/ibus-table/ibus-table-1.9.21-r2.ebuild (renamed from app-i18n/ibus-table/ibus-table-1.9.21-r1.ebuild)14
2 files changed, 26 insertions, 2 deletions
diff --git a/app-i18n/ibus-table/ibus-table-1.9.18-r1.ebuild b/app-i18n/ibus-table/ibus-table-1.9.18-r2.ebuild
index 3984c4333630..32a4746c5041 100644
--- a/app-i18n/ibus-table/ibus-table-1.9.18-r1.ebuild
+++ b/app-i18n/ibus-table/ibus-table-1.9.18-r2.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite(+)"
-inherit python-single-r1
+inherit python-single-r1 xdg
DESCRIPTION="Tables engines for IBus"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
@@ -37,3 +37,15 @@ src_prepare() {
src_configure() {
econf $(use_enable nls)
}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/app-i18n/ibus-table/ibus-table-1.9.21-r1.ebuild b/app-i18n/ibus-table/ibus-table-1.9.21-r2.ebuild
index 35165054cd63..779ffde98ca3 100644
--- a/app-i18n/ibus-table/ibus-table-1.9.21-r1.ebuild
+++ b/app-i18n/ibus-table/ibus-table-1.9.21-r2.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite(+)"
-inherit python-single-r1
+inherit python-single-r1 xdg
DESCRIPTION="Tables engines for IBus"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
@@ -38,3 +38,15 @@ src_prepare() {
src_configure() {
econf $(use_enable nls)
}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}