summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-02 23:07:53 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-02 23:17:41 +0200
commit4e88aae6ebcbc3186cb19cfc2562326a25bba46a (patch)
treef3ae84cf88866852835425c01f981b22cba0480b /app-forensics
parentapp-emulation/ski: update HOMEPAGE (diff)
downloadgentoo-4e88aae6ebcbc3186cb19cfc2562326a25bba46a.tar.gz
gentoo-4e88aae6ebcbc3186cb19cfc2562326a25bba46a.tar.bz2
gentoo-4e88aae6ebcbc3186cb19cfc2562326a25bba46a.zip
app-forensics/honggfuzz: drop 2.5-r1
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/honggfuzz/Manifest1
-rw-r--r--app-forensics/honggfuzz/files/honggfuzz-2.0-no-werror.patch11
-rw-r--r--app-forensics/honggfuzz/files/honggfuzz-2.5_binutils239.patch51
-rw-r--r--app-forensics/honggfuzz/honggfuzz-2.5-r1.ebuild57
4 files changed, 0 insertions, 120 deletions
diff --git a/app-forensics/honggfuzz/Manifest b/app-forensics/honggfuzz/Manifest
index c7ef97138e2c..521bc1519fe1 100644
--- a/app-forensics/honggfuzz/Manifest
+++ b/app-forensics/honggfuzz/Manifest
@@ -1,2 +1 @@
-DIST honggfuzz-2.5.tar.gz 65224877 BLAKE2B 610a15a674cfa928eb4b4d9fda91e5494fe08be4b01857f390c36925872479c77b5424c06ed4df87ad791de29598d848d88eb5437d6f5f9bf9521ff67aaa5ded SHA512 d1ff23471372a3d9d62de768bda8beba0e75c49f9550bc106efb4ab49ea626c1ccc078f7a9950051a99fbc841615a81faae2c3b39270facd6c0064e28956c419
DIST honggfuzz-2.6.tar.gz 65227315 BLAKE2B 527d36dd66974b74be29e3dc22e22c893d0e35654a768bfd93c6a919de82841cc1552af2b479ac0d65ce2fcfd66886ca0e43bc95db5b8187c8d13191e65de320 SHA512 cdd97b65e679652be888b966e2c010fe29af262e88d6c94b94b2e78c88258c5c53b4928fdf9e8afe54029c0742c5dfb0f6f8e8cb8157093e7f5ffdcfa5c92fd4
diff --git a/app-forensics/honggfuzz/files/honggfuzz-2.0-no-werror.patch b/app-forensics/honggfuzz/files/honggfuzz-2.0-no-werror.patch
deleted file mode 100644
index c5d6b8060450..000000000000
--- a/app-forensics/honggfuzz/files/honggfuzz-2.0-no-werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -26,7 +26,7 @@ LD = $(CC)
- BIN := honggfuzz
- HFUZZ_CC_BIN := hfuzz_cc/hfuzz-cc
- HFUZZ_CC_SRCS := hfuzz_cc/hfuzz-cc.c
--COMMON_CFLAGS := -std=c11 -I/usr/local/include -D_GNU_SOURCE -Wall -Wextra -Werror -Wno-format-truncation -Wno-override-init -I.
-+COMMON_CFLAGS := -std=c11 -I/usr/local/include -D_GNU_SOURCE -Wall -Wextra -Wno-format-truncation -Wno-override-init -I.
- COMMON_LDFLAGS := -pthread -lm
- COMMON_SRCS := $(sort $(wildcard *.c))
- CFLAGS ?= -O3 -mtune=native -funroll-loops
diff --git a/app-forensics/honggfuzz/files/honggfuzz-2.5_binutils239.patch b/app-forensics/honggfuzz/files/honggfuzz-2.5_binutils239.patch
deleted file mode 100644
index af574bc495a0..000000000000
--- a/app-forensics/honggfuzz/files/honggfuzz-2.5_binutils239.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 23c3da7ea63e4a841fa0e181d173e16b437adff0 Mon Sep 17 00:00:00 2001
-From: Robert Swiecki <robert@swiecki.net>
-Date: Thu, 2 Jun 2022 23:17:49 +0200
-Subject: [PATCH] Always pass 4 arguments to init_disassemble_info(), no matter
- what's the declaration. binutils/libopcode offers an unstable interface
-
----
- linux/bfd.c | 23 +++++++++++++++++++++--
- 1 file changed, 21 insertions(+), 2 deletions(-)
-
-diff --git a/linux/bfd.c b/linux/bfd.c
-index 228365f69..236f050ec 100644
---- a/linux/bfd.c
-+++ b/linux/bfd.c
-@@ -197,6 +197,24 @@ static int arch_bfdFPrintF(void* buf, const char* fmt, ...) {
- return ret;
- }
-
-+static int arch_bfdFPrintFStyled(void* buf, int style HF_ATTR_UNUSED, const char* fmt, ...) {
-+ va_list args;
-+ va_start(args, fmt);
-+ int ret = util_vssnprintf(buf, _HF_INSTR_SZ, fmt, args);
-+ va_end(args);
-+
-+ return ret;
-+}
-+
-+/*
-+ * binutils/libopcode has an unstable public interface. At some point in time the function
-+ * init_disassemble_info() started taking 4 arguments instead of 3. Always pass 4 arguments to it,
-+ * no matter what's the declaration.
-+ */
-+static void arch_bfdInitDisassembleInfoStub(
-+ struct disassemble_info* info, char* instr, void* bfd_printf_func, void* bfd_printf_styled_func)
-+ __attribute__((weakref, alias("init_disassemble_info")));
-+
- void arch_bfdDisasm(pid_t pid, uint8_t* mem, size_t size, char* instr) {
- MX_SCOPED_LOCK(&arch_bfd_mutex);
-
-@@ -227,8 +245,9 @@ void arch_bfdDisasm(pid_t pid, uint8_t* mem, size_t size, char* instr) {
- return;
- }
-
-- struct disassemble_info info;
-- init_disassemble_info(&info, instr, arch_bfdFPrintF);
-+ struct disassemble_info info = {};
-+
-+ arch_bfdInitDisassembleInfoStub(&info, instr, arch_bfdFPrintF, arch_bfdFPrintFStyled);
- info.arch = bfd_get_arch(bfdh);
- info.mach = bfd_get_mach(bfdh);
- info.buffer = mem;
diff --git a/app-forensics/honggfuzz/honggfuzz-2.5-r1.ebuild b/app-forensics/honggfuzz/honggfuzz-2.5-r1.ebuild
deleted file mode 100644
index 54fe2dc7889f..000000000000
--- a/app-forensics/honggfuzz/honggfuzz-2.5-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A general purpose fuzzer with feedback support"
-HOMEPAGE="https://honggfuzz.dev/"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="clang"
-
-RDEPEND="
- >=sys-libs/binutils-libs-2.29:=
- sys-libs/libunwind:=
- app-arch/xz-utils
- clang? ( sys-libs/blocksruntime )
-"
-
-DEPEND="${RDEPEND}
- elibc_musl? ( sys-libs/queue-standalone )"
-
-DOCS=(
- CHANGELOG
- COPYING
- CONTRIBUTING.md
- README.md
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0-no-werror.patch
- "${FILESDIR}"/${PN}-2.5_binutils239.patch
-)
-
-pkg_pretend() {
- if tc-is-clang; then
- use clang || die "${P}: to use clang enable USE=clang for ${P} (bug #729256)."
- fi
-}
-
-src_prepare() {
- default
- tc-export AR CC
- export CFLAGS
- export LDFLAGS
-}
-
-src_install() {
- dobin ${PN}
- dobin hfuzz_cc/hfuzz-cc
-
- einstalldocs
-}