summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-26 17:36:00 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-26 17:58:47 +0300
commitb12feba70d89461500f1e2368dc3e4d54147d53c (patch)
tree7cd798ccf1e53d48e56b58dbfeab05bf3aa260d3 /app-emulation
parentdev-python/dill: Stabilize 0.3.8-r2 ALLARCHES, #936666 (diff)
downloadgentoo-b12feba70d89461500f1e2368dc3e4d54147d53c.tar.gz
gentoo-b12feba70d89461500f1e2368dc3e4d54147d53c.tar.bz2
gentoo-b12feba70d89461500f1e2368dc3e4d54147d53c.zip
app-emulation/virtualbox-modules: add 7.1.0_beta1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox-modules/Manifest1
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-7.1.0_beta1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index 3a876e1356cb..8620eefe8a73 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -1,3 +1,4 @@
DIST vbox-kernel-module-src-6.1.50.tar.xz 680700 BLAKE2B c3a10ce8f3eb7e6c0c05f81cd3c072296557b9f9f6f501bb0aec3f04aabfe1fbb67b553510104139cef290c09ff9e67161085781b8d28c968dfafd15958a1b1a SHA512 7822e421b595263cbdaae08103255742360ca7ab0c385818ec895f10570c5b9ed5c7614742d8fa8bc2414cd426907cd1c49d735cde8caf9d2b7692898058f592
DIST vbox-kernel-module-src-7.0.18.tar.xz 719604 BLAKE2B 44e9d895791a7ff50681dd8860456a87078b41a4eb3005a6b249f9b34c37de709e190cbd6f352d21010ddcb9d8d1c35303bafd765e999664288df9e0ead94e6c SHA512 1cc17e302ef8251abd08a078abf11fede242154b0bb78d03f8d7c2821ba7cff410bd255802316a2f13100884b35a6f14fdf0b594304bd041521b66d264f51b77
DIST vbox-kernel-module-src-7.0.20.tar.xz 720160 BLAKE2B 833aa87af13a6c3e9426bd00e32b14c8b3958ab14425e8c02141d8579e987255b170662e00abb92f17234d4f03462d6d5b9fc1279d9da5449d344a328c905c8f SHA512 650bb6cf16ae42774524bf2e7ad2ee125d7a8d57de1e58d24b8b49bb9cf2829ea01dd32d2c1e0b2df556eab4a458cb0d84715b92d4085d03891f62a46aaf2916
+DIST vbox-kernel-module-src-7.1.0_beta1.tar.xz 738208 BLAKE2B 86a1edbfdf5505ccda2f8c3024570b7797e0d81b3c9ce7f9c3c3bf33d997558f93a660d20e29dc9da3ad0d9ae81300132f702d76756b9967c9d8d2e5b2947f67 SHA512 6b3ecbcc2a57d8292df6c4d880ebd9378245ff2eda1e623e7efefe9d99badce93a9ad5416c24a7e25ba0a81c8965407abb946cd858b9641db4e0945f4cc66c7a
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-7.1.0_beta1.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-7.1.0_beta1.ebuild
new file mode 100644
index 000000000000..0c1f6c073492
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-7.1.0_beta1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from VirtualBox-*.run
+# XXX: update: now it is split from virtualbox-*-Debian~bullseye_amd64.deb
+
+EAPI=8
+
+inherit linux-mod-r1
+
+MY_P="vbox-kernel-module-src-${PV}"
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="https://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${MY_P}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+# Still in beta
+#KEYWORDS="~amd64"
+
+CONFIG_CHECK="~!SPINLOCK JUMP_LABEL"
+
+src_compile() {
+ local modlist=( {vboxdrv,vboxnetflt,vboxnetadp}=misc )
+ local modargs=( KERN_DIR="${KV_OUT_DIR}" KERN_VER="${KV_FULL}" )
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+ insinto /usr/lib/modules-load.d/
+ newins "${FILESDIR}"/virtualbox.conf-r1 virtualbox.conf
+}