summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-10 15:16:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-10 15:27:09 -0400
commit554556537f7bb5ded6558156a87cbd72b8b3e1ec (patch)
tree34b0661895ee804703056507a99a7dce2c90a93a /app-emulation/wine-vanilla
parentnet-libs/nodejs: add 20.5.1 (diff)
downloadgentoo-554556537f7bb5ded6558156a87cbd72b8b3e1ec.tar.gz
gentoo-554556537f7bb5ded6558156a87cbd72b8b3e1ec.tar.bz2
gentoo-554556537f7bb5ded6558156a87cbd72b8b3e1ec.zip
app-emulation/wine-vanilla: respect CROSS*FLAGS again
Oops, overlooked while changing this around. Now with more syntax highlighting confusion for vim. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-vanilla')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild8
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
index 6a19271a4121..f68c984f64a3 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
@@ -271,7 +271,7 @@ src_configure() {
ac_cv_prog_x86_64_CC="${mingwcc_amd64}"
ac_cv_prog_i386_CC="${mingwcc_x86}"
- CROSSCFLAGS="$(
+ CROSSCFLAGS="${CROSSCFLAGS:-$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
@@ -282,13 +282,13 @@ src_configure() {
use custom-cflags || append-cflags -mno-avx
CC=${mingwcc} test-flags-CC ${CFLAGS:--O2}
- )"
+ )}"
- CROSSLDFLAGS="$(
+ CROSSLDFLAGS="${CROSSLDFLAGS:-$(
filter-flags '-fuse-ld=*'
CC=${mingwcc} test-flags-CCLD ${LDFLAGS}
- )"
+ )}"
)
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 6a19271a4121..f68c984f64a3 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -271,7 +271,7 @@ src_configure() {
ac_cv_prog_x86_64_CC="${mingwcc_amd64}"
ac_cv_prog_i386_CC="${mingwcc_x86}"
- CROSSCFLAGS="$(
+ CROSSCFLAGS="${CROSSCFLAGS:-$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
@@ -282,13 +282,13 @@ src_configure() {
use custom-cflags || append-cflags -mno-avx
CC=${mingwcc} test-flags-CC ${CFLAGS:--O2}
- )"
+ )}"
- CROSSLDFLAGS="$(
+ CROSSLDFLAGS="${CROSSLDFLAGS:-$(
filter-flags '-fuse-ld=*'
CC=${mingwcc} test-flags-CCLD ${LDFLAGS}
- )"
+ )}"
)
fi