summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-04-09 10:58:18 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-04-09 11:00:34 -0400
commit8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7 (patch)
tree7ebe531d0db758f278e7edfe757cb54b23d0bf77 /app-emulation/wine-mono/wine-mono-7.2.0.ebuild
parentdev-python/zope-configuration: Sync python_test with zope-interface (diff)
downloadgentoo-8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7.tar.gz
gentoo-8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7.tar.bz2
gentoo-8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7.zip
app-emulation/wine-mono: Sync with ::wine
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono/wine-mono-7.2.0.ebuild')
-rw-r--r--app-emulation/wine-mono/wine-mono-7.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/wine-mono-7.2.0.ebuild b/app-emulation/wine-mono/wine-mono-7.2.0.ebuild
new file mode 100644
index 000000000000..0836b039a90f
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}