summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2019-04-07 20:08:54 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-04-07 21:29:38 -0500
commit3baa88f281263a16d7143d866dd1f8e5e26bbba0 (patch)
tree9a7b5ae3654061d7acb992617e271296614c6da3 /app-emulation/libvirt/libvirt-9999.ebuild
parentnet-misc/rygel: x86 stable (bug #682116) (diff)
downloadgentoo-3baa88f281263a16d7143d866dd1f8e5e26bbba0.tar.gz
gentoo-3baa88f281263a16d7143d866dd1f8e5e26bbba0.tar.bz2
gentoo-3baa88f281263a16d7143d866dd1f8e5e26bbba0.zip
app-emulation/libvirt: Check for more kernel configs for virtual net
After 7431b3eb9a05068e4b Libvirt starts to create chains to insert rules into instead of placing them right at the top level chains. These private chains are created on daemon startup and the referenced commit made all 6 tables required (combination of default 3 tables: nat, filter and mangle for both IPv4 and IPv6). This was later refined in 686803a1a2e1e06, but it still makes sense for ebuild to check for all tables being enabled in the kernel because both IPv4 and IPv6 are used widely. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Closes: https://bugs.gentoo.org/681010 Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 39626cb3fae9..71ce26a41fbc 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -187,7 +187,14 @@ pkg_setup() {
~NETFILTER_ADVANCED
~NETFILTER_XT_CONNMARK
~NETFILTER_XT_MARK
- ~NETFILTER_XT_TARGET_CHECKSUM"
+ ~NETFILTER_XT_TARGET_CHECKSUM
+ ~IP_NF_FILTER
+ ~IP_NF_MANGLE
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ ~IP6_NF_FILTER
+ ~IP6_NF_MANGLE
+ ~IP6_NF_NAT"
# Bandwidth Limiting Support
use virt-network && CONFIG_CHECK+="
~BRIDGE_EBT_T_NAT