summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-20 19:59:02 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-20 20:00:27 +0100
commit50906ed198bd2d5e37dda6b4cb8fb8da0e92406c (patch)
tree19c0d546e3134277e1a6861ea96f3f5ba5fea17c /app-emulation/docker-compose
parentvirtual/linux-sources: Permit gentoo-kernel* (diff)
downloadgentoo-50906ed198bd2d5e37dda6b4cb8fb8da0e92406c.tar.gz
gentoo-50906ed198bd2d5e37dda6b4cb8fb8da0e92406c.tar.bz2
gentoo-50906ed198bd2d5e37dda6b4cb8fb8da0e92406c.zip
app-emulation/docker-compose: 1.25.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.2.ebuild73
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.25.2-setup-py.patch71
3 files changed, 145 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 9e871f331a98..c5f61faece31 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -2,3 +2,4 @@ DIST docker-compose-1.24.0.tar.gz 307601 BLAKE2B cb2a6f96e14c04d0279b25c075182d8
DIST docker-compose-1.24.1.tar.gz 307749 BLAKE2B 7ded0a4b82a7a9beb9de38752f38998ca4ea9421e5ed5630627820ec7e250ad6f03f6788bcbebe8bc0dd4c064d275bb4ca5a6055a95b6a0f72d7ae9038ec7f22 SHA512 9b8632ef263b8dfa678e8b99b46e00441f779716a524280ce25f62fcd2605f400723b7790c466338374c34653946dc2c5d7f09593ddd892fee3409c2a2fd1a5f
DIST docker-compose-1.25.0.tar.gz 320048 BLAKE2B a0615c9d81f897f551d664799e2a7cd4d72c3e0b70ceb0ff9bfb533a81799d2d524824ead27bff2391c5e98fc34430fb2ba724bba663ece66417ac72181241f0 SHA512 38be153a8ba1bf1a4a5c63dc794db3344c93c0819fba0c38feb791067e0aa72142205e4255b5fd31bf2f8159dfa04cde09fdcdabe0511bc0e2865974dff5433d
DIST docker-compose-1.25.1.tar.gz 321627 BLAKE2B 9056b0e359ff6cccba16b7ea5fc96de363f242103c48d15e3ed19ed5291878f7a5c81f99b7fd3eff46eaff5b271e883125ab02ff22bf592c4a5dd12792790fdc SHA512 5e58edd3364caecc9b6ec0e92e629e624694e42f96da836378648918dfaa41ddc0c99b107f2d3f11d1dd6ab86a516a7b2da3783b542623440d8c0c6628c05020
+DIST docker-compose-1.25.2.tar.gz 306196 BLAKE2B 6bf9c1ae14b25f41a7b3893f5ddc5b654743b29eb17c3d1b23e47d004e8e3feaf021b67c2419632faa6b11713ad1bd956b9f756e36fcd8efc7e60404a1de53a7 SHA512 ce045c6af233d6d03fd26100bce836444abb3022d6661ac6073cd8c6b8ed1cc0bbef9cbfad73672c8d3b6f3a12ee98e6e60c5f1b90360f778d5fa8d18e00179e
diff --git a/app-emulation/docker-compose/docker-compose-1.25.2.ebuild b/app-emulation/docker-compose/docker-compose-1.25.2.ebuild
new file mode 100644
index 000000000000..7bdd266df6a4
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.25.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+
+DEPEND="${RDEPEND}
+ test? (
+ <dev-python/pytest-4[${PYTHON_USEDEP}]
+ dev-python/ddt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )"
+
+S="${WORKDIR}/compose-${PV}"
+
+PATCHES=(
+ # Bug #679968 -- https://bugs.gentoo.org/679968
+ # Bug #681002 -- https://bugs.gentoo.org/681002
+ "${FILESDIR}"/${PN}-1.25.2-setup-py.patch
+)
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.25.2-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.25.2-setup-py.patch
new file mode 100644
index 000000000000..3af8d2de06e6
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.25.2-setup-py.patch
@@ -0,0 +1,71 @@
+From 19d9b58b97127f24e2280e3119e420393e7d239f Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 20 Jan 2020 19:27:46 +0100
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 38 +++++++++++++++++++-------------------
+ 1 file changed, 19 insertions(+), 19 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 110441d..3f6a46f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,35 +30,35 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 1',
+- 'PyYAML >= 3.10, < 6',
+- 'requests >= 2.20.0, < 3',
+- 'texttable >= 0.9.0, < 2',
+- 'websocket-client >= 0.32.0, < 1',
+- 'docker[ssh] >= 3.7.0, < 5',
+- 'dockerpty >= 0.4.1, < 1',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 4',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.20.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker[ssh] >= 3.7.0',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+ tests_require = [
+- 'pytest < 6',
++ 'pytest',
+ ]
+
+
+ if sys.version_info[:2] < (3, 4):
+- tests_require.append('mock >= 1.0.1, < 4')
++ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.2"': ['subprocess32 >= 3.5.4, < 4'],
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
+- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
+- ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
+- 'ipaddress >= 1.0.16, < 2'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ ':python_version < "3.2"': ['subprocess32 >= 3.5.4'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
++ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
++ ':python_version < "3.3"': ['backports.shutil_get_terminal_size >= 1.0.0',
++ 'ipaddress >= 1.0.16'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.24.1
+