summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-09 14:25:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-09 14:31:50 +0200
commitbd293596c0a0247a1d589a7d2ebc7a5c7a062346 (patch)
tree5978d7f8ec3cdce119fd1510c210eb530d1d1ba7 /app-emacs
parentnet-analyzer/gvm: drop 10.0.1, 11.0.0, 20.8.0 (diff)
downloadgentoo-bd293596c0a0247a1d589a7d2ebc7a5c7a062346.tar.gz
gentoo-bd293596c0a0247a1d589a7d2ebc7a5c7a062346.tar.bz2
gentoo-bd293596c0a0247a1d589a7d2ebc7a5c7a062346.zip
app-emacs/treemacs: bump to 2.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/treemacs/Manifest1
-rw-r--r--app-emacs/treemacs/treemacs-2.10.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/treemacs/Manifest b/app-emacs/treemacs/Manifest
index 6ce00e3b55f9..e3daff3ffdcf 100644
--- a/app-emacs/treemacs/Manifest
+++ b/app-emacs/treemacs/Manifest
@@ -1 +1,2 @@
+DIST treemacs-2.10.tar.gz 4137468 BLAKE2B 0f832d02f8b0f96f7000c57b1842319155face5cb50c44ff4286f7f28dd74b38739079de9c387dbddbf93af37a5c750c45a598100ed5053674a565b4ec34f0c6 SHA512 9326a3f66c1b38eb7ef39e90900c2ef71d20c6c3478213f61c144ca4face562dccf00d6d400315c264627468a0c3319a24f0ec6cddb795b54e1b7f3c235d1c71
DIST treemacs-2.9.5.tar.gz 4134227 BLAKE2B 1fbdb278e9524fdb14cbc7699bc787ab694b00d37a91ec3e91e106079bc02f6b8b39207608873d45c70fd6355a22553bf1a0636a948b79df77adfe0b4a3f799f SHA512 adc026d7ad459418fae531c5a1a7df7f9308e63dec82240c1c5e278eb00fdf8d6dff1ee2112ea73d5a05c4266efe24623bb84f8819a6f07fbb4fde6e644ca9ad
diff --git a/app-emacs/treemacs/treemacs-2.10.ebuild b/app-emacs/treemacs/treemacs-2.10.ebuild
new file mode 100644
index 000000000000..ea3b8ab8544a
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-2.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+PATCHES=( "${FILESDIR}"/${PN}-icons-icon-directory.patch )
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i src/elisp/${PN}-icons.el || die
+}
+
+src_compile() {
+ elisp-compile src/elisp/*.el
+}
+
+src_test() {
+ buttercup ${BYTECOMPFLAGS} -L test --traceback full || die
+}
+
+src_install() {
+ elisp-install ${PN} src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto ${SITEETC}/${PN}
+ doins -r icons
+}