summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-11 01:17:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-11 01:28:43 +0100
commit7f0e0854a2d60ba6d699b50429eff7bd0e0864da (patch)
tree026a67a563d255ba284c98a81a47f69b7610e68f /app-emacs
parentapp-emacs/org-mode: bump to 9.7.17 (diff)
downloadgentoo-7f0e0854a2d60ba6d699b50429eff7bd0e0864da.tar.gz
gentoo-7f0e0854a2d60ba6d699b50429eff7bd0e0864da.tar.bz2
gentoo-7f0e0854a2d60ba6d699b50429eff7bd0e0864da.zip
app-emacs/transient: bump to 0.8.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.8.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index edf35e91f174..35331b64a6d8 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1 +1,2 @@
DIST transient-0.7.9.tar.gz 144323 BLAKE2B 458fc59484d9a8b39e6810ece2f7eea43493d58107b3bf0950f87c6325ed7812b87eddb335a00094bd298e4a7a71b42a1388c8cf4d4e6f6cba0cea53fd6b6cfa SHA512 176082cc56d495d5fb0776abf16a9ddbe45fc0c0efefa6b1d2724689134ecacdb9630fa4b2d5034e16c716f0772a921125602b09ee07acb013e026eb55ff4998
+DIST transient-0.8.1.tar.gz 152761 BLAKE2B cc62becaff81b803cf0a7c843b1da4996cd06171ac151c1e54381f4e3d54b1b17105557577bd3fe1ae8fca2041c556dccbaf6a000ed1eef14434404b7f8022c5 SHA512 7d278452dbbd259654aa5f9576b94613224b7243f26445a364081a7e50eaf8fcc82d2699dceeffdd9a1364bcd4bc27af139b73ac90c251c45332247c0fe61c66
diff --git a/app-emacs/transient/transient-0.8.1.ebuild b/app-emacs/transient/transient-0.8.1.ebuild
new file mode 100644
index 000000000000..f99ae40b0465
--- /dev/null
+++ b/app-emacs/transient/transient-0.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}