summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-02 13:26:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-02 16:11:29 +0200
commit4e56d87d9b7f2760ba628cd3898f72e3b24f4839 (patch)
tree94cc0c6a999a4a607637646fce2e8d6739eca26c /app-emacs
parentsci-electronics/nvc: bump to 1.10.1 (diff)
downloadgentoo-4e56d87d9b7f2760ba628cd3898f72e3b24f4839.tar.gz
gentoo-4e56d87d9b7f2760ba628cd3898f72e3b24f4839.tar.bz2
gentoo-4e56d87d9b7f2760ba628cd3898f72e3b24f4839.zip
app-emacs/compat: bump to 29.1.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.4.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index e11b3c489c49..427a744a39f3 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,3 +1,4 @@
DIST compat-29.1.3.3.tar.gz 124534 BLAKE2B 680a404a4819ebbd95f94e2112f8fe3e08cd7c47204319f231c844bdc064153e7df0f653ac9614e6b6185f30b4e82b52aeb8317d74f5aa1c89252c4e6b6afa52 SHA512 fb69e2cff11daea1e3ba6a4755dccb81850c0e64b335978c5a30cb8236108ae369149d8f2e04746884281c01535aba6e6c5ac3c319497d511ecdd090bed83510
DIST compat-29.1.4.0.tar.gz 127066 BLAKE2B e070ee6f64ad8a0ead91e8ef5fb6bdad95e4f0a8d16f8e513fcd60a91714f0fe2d8d084a23be5d6421d7129c603186db5ec80af3f2725f288e15c846c571ea3f SHA512 027341e06ab9f3c6c109a1bfee513b7ac1b472ed9e7002f731be2fa944920ec6805a928f69c7369ab98c818cee87dd3dfe0c217a4595752701f9939171f9f4de
DIST compat-29.1.4.1.tar.gz 127809 BLAKE2B e558747786932f49643d0869b2a4e9c8a6cae1e2386c99a65584ef55a9ba54ed00f172b86372a23f6fe43a1565c16d5e3e08933e3636c6e36344a8bd7d38e347 SHA512 3ebb02a8c41e056e7414f9c978066e888e58cc53b420f63051a6c46d486be2735517f03dbc191d4fefa3a058c469c9d718c9cd5f951745c5c09d9603352b7572
+DIST compat-29.1.4.2.tar.gz 128695 BLAKE2B e02d431c307b08d07888362a20fb597cfcb275b645522229a116169eff7f875ff3dbf23bb1344249fa8ac2b25cf7ade20752ce9e97188a49d851ba5ae1dfa8cb SHA512 a31fb1564b1bad20f0f7a0a400e9834e88c2e21b8c022ce4696e27cddc351b7c882765235accde0b3f4a417680699bc5bb69f7485436c8e64d799e8a5ac9e390
diff --git a/app-emacs/compat/compat-29.1.4.2.ebuild b/app-emacs/compat/compat-29.1.4.2.ebuild
new file mode 100644
index 000000000000..4c6643fbd200
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}