summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Turner <jturner.usa+gentoo@gmail.com>2021-12-06 19:32:13 -0500
committerSam James <sam@gentoo.org>2021-12-08 02:46:06 +0000
commit2692881d69e8aa549d9b8e26bcd5467b3d3a1bb0 (patch)
tree58a28a2ae0368ab273ca30338befd19c99ba8501 /app-emacs
parentdev-lang/python: skip known-hanging/fragile tests for PGO (diff)
downloadgentoo-2692881d69e8aa549d9b8e26bcd5467b3d3a1bb0.tar.gz
gentoo-2692881d69e8aa549d9b8e26bcd5467b3d3a1bb0.tar.bz2
gentoo-2692881d69e8aa549d9b8e26bcd5467b3d3a1bb0.zip
app-emacs/projectile: initial import
Signed-off-by: John Turner <jturner.usa+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23206 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/projectile/Manifest1
-rw-r--r--app-emacs/projectile/files/50projectile-gentoo.el2
-rw-r--r--app-emacs/projectile/metadata.xml16
-rw-r--r--app-emacs/projectile/projectile-2.5.0.ebuild25
4 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/projectile/Manifest b/app-emacs/projectile/Manifest
new file mode 100644
index 000000000000..1a31170312ff
--- /dev/null
+++ b/app-emacs/projectile/Manifest
@@ -0,0 +1 @@
+DIST projectile-2.5.0.tar.gz 1915860 BLAKE2B 4d215e2c1e44c7f85121fc36445112f3064129fe95866b4fbb2e14b11d31519057d9cc69bcdf44c82cd516768cc73a031da48a7c5352b9825816db54810cafcb SHA512 3faeb7db70e5e2198ad307c1d5d24a5fadd207765387e7094691e40071411506e6df690995f923bf246b7176173ca41882d369276862b631d7436747bfeae3a3
diff --git a/app-emacs/projectile/files/50projectile-gentoo.el b/app-emacs/projectile/files/50projectile-gentoo.el
new file mode 100644
index 000000000000..05c734668e49
--- /dev/null
+++ b/app-emacs/projectile/files/50projectile-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/projectile-autoload.el")
diff --git a/app-emacs/projectile/metadata.xml b/app-emacs/projectile/metadata.xml
new file mode 100644
index 000000000000..c74f950ffe52
--- /dev/null
+++ b/app-emacs/projectile/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jturner.usa+gentoo@gmail.com</email>
+ <name>John Turner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bbatsov/projectile</remote-id>
+ <doc>https://github.com/bbatsov/projectile/blob/master/README.md</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/projectile/projectile-2.5.0.ebuild b/app-emacs/projectile/projectile-2.5.0.ebuild
new file mode 100644
index 000000000000..6a9e19ad606d
--- /dev/null
+++ b/app-emacs/projectile/projectile-2.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="25.1"
+
+inherit elisp
+
+DESCRIPTION="A project interaction library for Emacs"
+HOMEPAGE="https://docs.projectile.mx"
+SRC_URI="https://github.com/bbatsov/projectile/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50projectile-gentoo.el"
+DOCS=( README.md )
+RESTRICT="test" # tests require buttercup which is not packaged
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}