summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-07-01 21:56:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-07-01 22:00:31 +0200
commit12e15ce461b84e18bafdf893565121a22366c5a3 (patch)
tree865417585bcc4ce0570d205222648e6115a560c0 /app-emacs
parentmedia-radio/svxlink: add 24.02 (diff)
downloadgentoo-12e15ce461b84e18bafdf893565121a22366c5a3.tar.gz
gentoo-12e15ce461b84e18bafdf893565121a22366c5a3.tar.bz2
gentoo-12e15ce461b84e18bafdf893565121a22366c5a3.zip
app-emacs/scala-ts-mode: add 1.0.0_p20240630
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/scala-ts-mode/Manifest1
-rw-r--r--app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240630.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/scala-ts-mode/Manifest b/app-emacs/scala-ts-mode/Manifest
index 135433dd008d..18839f6bc4b7 100644
--- a/app-emacs/scala-ts-mode/Manifest
+++ b/app-emacs/scala-ts-mode/Manifest
@@ -1 +1,2 @@
DIST scala-ts-mode-1.0.0_p20240316.tar.gz 18330 BLAKE2B aedcfa91563421673435def9dc2679d5c9f1feb1dde6214e8e7650ca8d72e6165253140bc506ba67cbc00b4e54d9edbb34db47089438b6de2e42699bf15ebfa7 SHA512 544622840cfefbab79ddae06d48cc5a9a6fb1802fd18f7c2b425b921713392e6d84b287dcdb3fa65d08d59f5af28ec2b23711685764affaf854238d3583b0cd3
+DIST scala-ts-mode-1.0.0_p20240630.tar.gz 18354 BLAKE2B c46f349d90f51f3e5b90f1f852f03c56f5b6f7ccf2efe72d272e82d348aca3d0abeda7402ecc420efcef1fd349987c16633564d8d5cfed05bb4aadeedcee5653 SHA512 a7595e2cb5742048a8174b38d28d0d07ebaf8a74ff8f5f695261874c86faf51e7ed3664701b4b7c9e20c03f5c73d706070bbe6ec09d73364ea9a9f3000524f18
diff --git a/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240630.ebuild b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240630.ebuild
new file mode 100644
index 000000000000..b88012a0d9b4
--- /dev/null
+++ b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240630.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_COMMIT="8c4ace721fb525d1a790121a8625bc2623c9f207"
+DESCRIPTION="Emacs Scala Mode via Tree-Sitter"
+HOMEPAGE="https://github.com/KaranAhlawat/scala-ts-mode"
+SRC_URI="
+ https://codeload.github.com/KaranAhlawat/scala-ts-mode/tar.gz/${MY_COMMIT}
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-editors/emacs-29[tree-sitter]
+ dev-libs/tree-sitter-scala
+"
+
+DOCS="README.org"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}