summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-10 01:59:37 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-10 02:04:36 +0100
commitcb18383f72e361b80c3a7e9baf529c570037bbad (patch)
tree9f15a6e246d6862e653935c3bb1260ccfd150bb5 /app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
parentapp-emacs/julia-mode: new package; add 0.4_p20211023 (diff)
downloadgentoo-cb18383f72e361b80c3a7e9baf529c570037bbad.tar.gz
gentoo-cb18383f72e361b80c3a7e9baf529c570037bbad.tar.bz2
gentoo-cb18383f72e361b80c3a7e9baf529c570037bbad.zip
app-emacs/julia-repl: new package; add 1.3.0_p20220225
2022.02.25 snapshot Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild')
-rw-r--r--app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
new file mode 100644
index 000000000000..b52af57974bd
--- /dev/null
+++ b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=6c1d63511fb2b3b3f2e342eff6a375d78be6c12c
+NEED_EMACS=25.1
+
+inherit optfeature elisp
+
+DESCRIPTION="Run an inferior Julia REPL in a terminal inside Emacs"
+HOMEPAGE="https://github.com/tpapp/julia-repl/"
+SRC_URI="https://github.com/tpapp/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-emacs/s"
+RDEPEND="
+ ${BDEPEND}
+ app-emacs/julia-mode
+"
+
+DOCS=( CHANGELOG.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-force-compile.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l ert -l ./${PN}-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ rm ./${PN}-tests.el || die
+
+ elisp_src_install
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "running Julia inside VTerm" app-emacs/vterm
+}