summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-08 18:48:26 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-08 20:22:41 +0100
commit36b4bbe637bd017ceedfd326f5293e236cabd66c (patch)
tree7726fc7bc4f4a6eb08964bbe8a8372c73713e31d /app-emacs/doom-themes
parentapp-emacs/doom-themes: bump to 2.3.0_p20231208 (diff)
downloadgentoo-36b4bbe637bd017ceedfd326f5293e236cabd66c.tar.gz
gentoo-36b4bbe637bd017ceedfd326f5293e236cabd66c.tar.bz2
gentoo-36b4bbe637bd017ceedfd326f5293e236cabd66c.zip
app-emacs/doom-themes: add live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/doom-themes')
-rw-r--r--app-emacs/doom-themes/doom-themes-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/doom-themes/doom-themes-9999.ebuild b/app-emacs/doom-themes/doom-themes-9999.ebuild
new file mode 100644
index 000000000000..96c464e3ae78
--- /dev/null
+++ b/app-emacs/doom-themes/doom-themes-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Opinionated megapack of modern color-themes for GNU Emacs"
+HOMEPAGE="https://github.com/doomemacs/themes/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/doomemacs/themes.git"
+else
+ SRC_URI="https://github.com/doomemacs/themes/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/themes-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITELISP}"/${PN}
+ doins -r themes
+}