summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-06 20:17:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-06 20:17:50 +0100
commit5baa06cd0fddd5413c8596d1e1891590ce1a0b75 (patch)
treef92b927c5a230f47dd0f6bf2392c4971f2a993e3 /app-emacs/compat
parentdev-tcltk/tkimg: avoid use of svn (diff)
downloadgentoo-5baa06cd0fddd5413c8596d1e1891590ce1a0b75.tar.gz
gentoo-5baa06cd0fddd5413c8596d1e1891590ce1a0b75.tar.bz2
gentoo-5baa06cd0fddd5413c8596d1e1891590ce1a0b75.zip
app-emacs/compat: bump to 29.1.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.0.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 00540f6cf09b..063aef223227 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,3 +1,4 @@
DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
DIST compat-28.1.2.1.tar.gz 82434 BLAKE2B daf82d8f44af3f1b20dd25d042f401623d84f64a54c3b919714cd13fe4100d3b332e323a5fea5a643cdfc2dfe8b76a6a5684ad676fc595901df50a43e44b82f2 SHA512 7d2697b9b5bce25f44ab67438dd2b99bbd5072ed15193264cbd35473796d711d2b8f40db126478ea3c5de55609881ee20555e8a91d075df03f20610164f05d89
DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289dbdaccb0f9ca5cbd44cb1e41b9b7b4b52394548658b47216f9205f28d2020b015d22b5d0c4df63c79794ddfc56e SHA512 65cafbf4d48815f447e412c4dbd87c5bd3357df5302660a5296582648926f8e3fe96b4b90b53674f18be8affe66af95c8db7e58d7a9dd63d2b57983962e5a53c
+DIST compat-29.1.0.1.tar.gz 98171 BLAKE2B 46fd4052b7e3f6deb7789cb50d2d6c19d698531de04a171b3afc9035ed6ff3e204ee58e770eb699c05d722141b409e34dc13df1af6e3cda275ff107759a0a957 SHA512 51af7d1f87c838d421f017f2bdcce215e6951bd69181abff64c2c87f6ff1aac1b5f29e0dc91be2f48589e9a6092007a99d987791213801c7e0d89a372dfa4b72
diff --git a/app-emacs/compat/compat-29.1.0.1.ebuild b/app-emacs/compat/compat-29.1.0.1.ebuild
new file mode 100644
index 000000000000..8bc70c870235
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=8a32564247ad3baee571252a2004c3d347962d01
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}