summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-27 02:41:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-27 03:27:01 +0200
commit516aecf46e713c1ee804401a6437bbbff385fcf6 (patch)
tree13458e11b1090eaabc38ae64f9f3e64c776caa02 /app-emacs/compat
parentapp-emacs/eldev: drop old 1.1.2 (diff)
downloadgentoo-516aecf46e713c1ee804401a6437bbbff385fcf6.tar.gz
gentoo-516aecf46e713c1ee804401a6437bbbff385fcf6.tar.bz2
gentoo-516aecf46e713c1ee804401a6437bbbff385fcf6.zip
app-emacs/compat: bump to 28.1.2.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-28.1.2.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 298a7091b2e5..2333441dd226 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,2 +1,3 @@
DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
DIST compat-28.1.2.0.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
+DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289dbdaccb0f9ca5cbd44cb1e41b9b7b4b52394548658b47216f9205f28d2020b015d22b5d0c4df63c79794ddfc56e SHA512 65cafbf4d48815f447e412c4dbd87c5bd3357df5302660a5296582648926f8e3fe96b4b90b53674f18be8affe66af95c8db7e58d7a9dd63d2b57983962e5a53c
diff --git a/app-emacs/compat/compat-28.1.2.2.ebuild b/app-emacs/compat/compat-28.1.2.2.ebuild
new file mode 100644
index 000000000000..ef23dab91fee
--- /dev/null
+++ b/app-emacs/compat/compat-28.1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}