summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-10 15:30:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-10 15:37:12 +0200
commitca763e6e2cbab2c07c14365b4fe61e3f185842f6 (patch)
tree4d3230b82a4d04a4a72bd11845cf0200346fe0be /app-emacs/citar
parentapp-emacs/citeproc-el: new package; add version 0.9.1 (diff)
downloadgentoo-ca763e6e2cbab2c07c14365b4fe61e3f185842f6.tar.gz
gentoo-ca763e6e2cbab2c07c14365b4fe61e3f185842f6.tar.bz2
gentoo-ca763e6e2cbab2c07c14365b4fe61e3f185842f6.zip
app-emacs/citar: new package; add version 1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/citar')
-rw-r--r--app-emacs/citar/Manifest1
-rw-r--r--app-emacs/citar/citar-1.0.ebuild43
-rw-r--r--app-emacs/citar/files/50citar-gentoo.el2
-rw-r--r--app-emacs/citar/metadata.xml23
4 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
new file mode 100644
index 000000000000..1eac9a440400
--- /dev/null
+++ b/app-emacs/citar/Manifest
@@ -0,0 +1 @@
+DIST citar-1.0.tar.gz 1339812 BLAKE2B 2093cc820199219ec70f99a746c630f2b8e6b4d464b1457d7b7db1c5c953138e7dd5ac55e21b13e7417dd0a764b6f1caaf400af353ecce9fb7e1bc578f570b0d SHA512 7f02a4e41a927c2c7c625189fa38caea8f0fc5616dd3487a93f71a373d1e4a124dd1cc520778a1ff2fa6dd7c3b619b539e3b0e47cb9caf7edd16e27e9d739585
diff --git a/app-emacs/citar/citar-1.0.ebuild b/app-emacs/citar/citar-1.0.ebuild
new file mode 100644
index 000000000000..0f6a51de1eb0
--- /dev/null
+++ b/app-emacs/citar/citar-1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.org CONTRIBUTING.org README.org images )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citar/files/50citar-gentoo.el b/app-emacs/citar/files/50citar-gentoo.el
new file mode 100644
index 000000000000..6243866c44c2
--- /dev/null
+++ b/app-emacs/citar/files/50citar-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "citar-autoloads" nil t)
diff --git a/app-emacs/citar/metadata.xml b/app-emacs/citar/metadata.xml
new file mode 100644
index 000000000000..2ba5ec6831b5
--- /dev/null
+++ b/app-emacs/citar/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs package to quickly find and act on bibliographic references, and edit
+ org, markdown, and latex academic documents. This package provides a
+ completing-read front-end to browse and act on BibTeX, BibLaTeX, and CSL
+ JSON bibliographic data, and LaTeX, markdown, and org-cite editing support.
+ When used with vertico, embark, and marginalia, it provides similar
+ functionality to helm-bibtex and ivy-bibtex: quick filtering and selecting
+ of bibliographic entries from the minibuffer, and the option to run
+ different commands against them.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacs-citar/citar/issues/</bugs-to>
+ <remote-id type="github">emacs-citar/citar</remote-id>
+ </upstream>
+</pkgmetadata>