summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2024-01-31 21:01:30 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-29 14:44:20 +0200
commit824b749b2b7acd55d422a1bd82a4279b5bf5421e (patch)
tree7e25ac4b975b03c794e58766ce596bed4a5b93e8 /app-editors
parentapp-editors/remarkable: drop 1.9.0_pre20210320-r1 (diff)
downloadgentoo-824b749b2b7acd55d422a1bd82a4279b5bf5421e.tar.gz
gentoo-824b749b2b7acd55d422a1bd82a4279b5bf5421e.tar.bz2
gentoo-824b749b2b7acd55d422a1bd82a4279b5bf5421e.zip
app-editors/remarkable: fix custom css is not loaded on start
patch to fix https://github.com/jamiemcg/Remarkable/issues/345 Closes: https://bugs.gentoo.org/911722 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/35120 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/remarkable/files/fix-custom-css-issue.patch29
-rw-r--r--app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild70
2 files changed, 99 insertions, 0 deletions
diff --git a/app-editors/remarkable/files/fix-custom-css-issue.patch b/app-editors/remarkable/files/fix-custom-css-issue.patch
new file mode 100644
index 000000000000..4d45f18a01b4
--- /dev/null
+++ b/app-editors/remarkable/files/fix-custom-css-issue.patch
@@ -0,0 +1,29 @@
+From 09459c2e577a0ae2561e4f785efc026dcfb65809 Mon Sep 17 00:00:00 2001
+From: Nikita Zlobin <cook60020tmp@mail.ru>
+Date: Fri, 4 Aug 2023 23:56:43 +0500
+Subject: [PATCH] Fix issue #345 - apply custom css on start
+
+Just a typo, when default empty css was used on application start
+instead of configured.
+
+Fixes #345
+---
+ remarkable/RemarkableWindow.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/remarkable/RemarkableWindow.py b/remarkable/RemarkableWindow.py
+index d54aa32..45134ab 100755
+--- a/remarkable/RemarkableWindow.py
++++ b/remarkable/RemarkableWindow.py
+@@ -331,7 +331,7 @@ class RemarkableWindow(Window):
+ elif self.style == "solarized_light":
+ styles.set(styles.solarized_light)
+ elif self.style == "custom":
+- styles.set(styles.custom_css)
++ styles.set(self.custom_css)
+ else:
+ print("Style key error")
+
+--
+2.39.3
+
diff --git a/app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild b/app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild
new file mode 100644
index 000000000000..1525913a442f
--- /dev/null
+++ b/app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit desktop gnome2-utils python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="Fully featured markdown editor, supports github markdown dialect"
+HOMEPAGE="https://remarkableapp.github.io/ https://github.com/jamiemcg/remarkable"
+GIT_COMMIT="7b0b3dacef270a00c28e8852a88d74f72a3544d7"
+SRC_URI="https://github.com/jamiemcg/remarkable/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Remarkable-${GIT_COMMIT}"
+
+LICENSE="BSD-2 GPL-2+ LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ net-libs/webkit-gtk:4.1[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-spellcheck.patch
+ "${FILESDIR}"/webkit-version.patch
+ "${FILESDIR}"/fix-custom-css-issue.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s|import styles|from remarkable import styles|" \
+ -e "s|from findBar|from remarkable.findBar|" \
+ remarkable/RemarkableWindow.py || die
+}
+
+src_install() {
+ default
+
+ python_domodule markdown pdfkit remarkable remarkable_lib
+ python_doscript bin/remarkable
+ doicon data/ui/remarkable.png
+ domenu ${PN}.desktop
+
+ insinto /usr/share/${PN}
+ doins -r data/ui
+ doins -r data/media
+
+ insinto /usr/share/glib-2.0/schemas
+ doins data/glib-2.0/schemas/*
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}